2

I try install OPENssh ./configure

checking for openssl/opensslv.h... no configure: error: * OpenSSL headers missing

any idea?

  • As jamespo points out, are you sure you want to build it from source? Openssh is quite a critical attack vector if any exploits should be found, so it would be best to use the repositories so you get security updates. – Egil Apr 6 '11 at 9:50
6

I would install the openssh server package if you have a choice apt-get install openssh-server. However if you want to compile from source install openssl first.

Either from source or from the package: apt-get install libssl-dev openssl

2

To install dependencies needed to build a given package, you can use apt-get's build-dep option, e.g., apt-get build-dep openssh or apt-get build-dep openssh-server if you are trying to build the server.

1

It's likely you are missing the development headers for openssl. Try installing "openssl-devel".

  • @tijybba Can you remove your duplicate comment? – hexafraction Sep 16 '12 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.