5

I have a problem that I have been trying to fix over 3 months now, I'm using Ubuntu 12.04 64bit with Windows 7 as a Guest on VirtualBox, I have a USB Modem which doesn't support Linux, the Modem works good on the Guest but I don't know how to let the Host (Ubuntu) use that connection, I have searched around the Internet and most documents and fixes for how to share Host's connection with Guest, not Guest with Host. Beside, I've found some posts with similar problem but I couldn't understand the workarounds, I'm still beginner. So could anyone provide a step-by-step guide how to share Guest's Internet with Host? Thanks a lot!

5
  • 1
    A possible solution could be to set up a proxy or VPN server on your guest and connect to it from your host.
    – pcworld
    Aug 26, 2013 at 16:39
  • How I can do that?
    – user32655
    Aug 26, 2013 at 21:31
  • @pcworld Please explain how to do this (Step-by-Step). I have same problem and will appreciate any useful answer Mar 12, 2014 at 12:12
  • 1
    @pcworld that's a lot easier said than done on a Windows 7 guest. Not sure that's still a valid approach given that, nor am I sure that's on topic here
    – Thomas Ward
    Nov 29, 2015 at 17:30
  • Seems similar to this stackoverflow.com/questions/69842792/…
    – Nande
    Apr 22 at 1:41

2 Answers 2

1

There is a great answer at this post to create a host only connection for your Virtualbox that can be seen by Ubuntu to be used for connecting into your VM for network connection sharing.

In VirtualBox, how do I set up host-only virtual machines that can access the Internet?

Before you follow those directions you need to create the virtual connection. Copy and paste the following in a terminal window to create it:

vboxmanage hostonlyif create

Also, follow these instructions here after you have created the host only connection and have it configured to setup Internet Connection Sharing in your Windows VM so that you can share your connection.

http://windows.microsoft.com/en-us/windows/using-internet-connection-sharing#1TC=windows-7

0

make the network adapter a 'host-only" adapter ( just click devices menu above the running virtual machine and change the "attached to" network adapter setting to "Host-only" and then you will need to wait a few minutes while the changes propagate and/or you change the hosts network addresses to match the new guests host-only adapter address (192.168.0.1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.