1

I recently purchased Arduino Mega, and I'm tring it to make it communicate with Ubuntu 13.04 64bit, without success.

At arduino IDE the option Tools → Serial Port is grayed out.

Is there any driver I need to install?

1

See this link: http://www.ladyada.net/learn/arduino/lesson0-lin.html

If it does not work, you can use:

sudo apt-get install openjdk-6-jre avr-libc gcc-avr

I have an Arduino UNO and went through the same problem.

  • Thanks for your answer. I followed the guide but it stuck on the step that it says to type on terminal ls /dev/ttyUSB*. No such file or direcctory. I also tried the other options described at the guide, with no luck.. – Manos Aug 26 '13 at 15:33
  • Tried it? sudo apt-get install gcc-avr avr-libc – Patterson Aug 26 '13 at 15:46
  • imageshack.us/f/9/swma.png This is what i get – Manos Aug 26 '13 at 16:53
  • 1
    I fixed it.. Thanks.. I downloaded the 1.0.3 IDE version from ubuntu software center thats why it didnt worked. It worked great with 1.0.5!! – Manos Aug 26 '13 at 16:58
  • It is true! I also had installed version 1.0.5 – Patterson Aug 26 '13 at 17:25
0

Hey i found a solution to my problem

its simple download the arduino 1.0.5 from the website.

make sure you download java from java.com

the problem is in the |dailout| make sure you are registered in the it and everything will work just fine.

  • 2
    Could you give more details? How exactly I do that? Edit your question and be more verbose. – Braiam Sep 24 '13 at 14:22
0

If had the same problem with Ubuntu 16.04 and an Arduino Mega 2560 R3 where no /dev/ttyACM* device was created.

Output of dmesg was

usb 3-2: new full-speed USB device number 7 using xhci_hcd
usb 3-2: New USB device found, idVendor=2341, idProduct=0042
usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
usb 3-2: Manufacturer: Arduino (www.arduino.cc)
usb 3-2: SerialNumber: 854303432383514012A0
usb 3-2: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes

It turns out, the module cdc_acm which creates the device was not loaded so a simple

sudo modprobe cdc_acm

fixed the issue, port was selectable in Arduino IDE and worked flawlessly.

Dmesg then showed additionally:

cdc_acm 3-2:1.0: ttyACM0: USB ACM device
usbcore: registered new interface driver cdc_acm
cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.