Today I turned on my notebook and I couldn't connect to my network, it just keeps asking for my password. That's weird because I've been using it on this network forever and never saw this error.

So I restarted my router thinking that could be the problem, and nope, both my desktop computers connect fine but my notebook still can't connect.

So I boot my notebook on Windows 7 and it connects just fine, so it's not a hardware thing...

The encryption im using is WPA & WPA2 Personal, and the wireless card is RTL8111/8168 PCI Express Gigabit

Why can't I connect to wifi on my xubuntu notebook?

  • 1
    Welcome to Ask Ubuntu gosu! What exactly happens when you try to connect to your network? Does it repeatedly keep asking you for the password? Does it connect, but you can't access the internet? Please provide more information. – Alaa Ali Aug 26 '13 at 4:57
  • It repeatedly keeps asking for my password – gosukiwi Aug 26 '13 at 5:02
  • Follow the steps in this answer. If it doesn't fix it, follow the steps in this answer. If one of these fixes your issue, please report back on which one did. – Alaa Ali Aug 26 '13 at 5:18
  • what encryption are you using? what wireless network card you are using? – Mitch Aug 26 '13 at 5:18
  • The encryption im using is WPA & WPA2 Personal, the wireless card is RTL8111/8168 PCI EXpress Gigabit. @Alaa: I tried both, none of them worked. – gosukiwi Aug 26 '13 at 5:25

It turns out for some reason the drivers broke... I downloaded the drivers from Realtek and installed them, reboot, and it now works as a charm!

tar -xvzf myDriver.tar.gz
cd myDriver/
sudo make
sudo make install

Thanks to everyone who helped :)

EDIT: I had to follow this guide for a source code error on their driver code

  • Could you add more information about how did you installed it? – Lucio Aug 29 '13 at 2:18
  • Sorry I will post the formatted code in my answer – gosukiwi Aug 29 '13 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.