1

I am unable to access my tablet (Pipo S1) through adb - after running adb devices, there are no devices visible. USB debugging is enabled, and I have tried 2 different USB ports and cables.

I was able to find the vendor ID through lsusb, which is 2207. I added this ID to /etc/udev/rules.d/70-android.rules, 51-android.rules and 99-android.rules, after reading different conflicting information online. The exact line I added was:

SUBSYSTEM=="usb", SYSFS{idVendor}=="2207", MODE="0666", GROUP="adbusers"

Even after multiple server restarts, unplugging and re-plugging the device, I am still unable to see it. Any ideas? My end goal is to root this tablet without resorting to windows based apps.

  • Hidden in a comment to the answer here: askubuntu.com/questions/213874/… is the hint to put the .rules file to /lib/udev/rules.d rather than to /etc. Does this help? – Takkat Aug 25 '13 at 13:51
  • Unfortunately no. Still no devices found after moving the files and restarting adb. – Sasha Aug 25 '13 at 18:24
  • Sorry to hear, but it looked like worth a try. Here same issue btw. – Takkat Aug 25 '13 at 19:28
1

Check if the "adbusers" group exists in you system. If not, try to change it to "plugdev" in rules files, and add yourself to "plugdev" group.

In my case, i've just to install android-tools-adb, android-tools-fastboot, android-rules via apt, and edit files: /lib/udev/rules.d/51-android.rules, /lib/udev/rules.d/51-android-rules.rules for replacing "adbusers" with "plugdev". So now my tablet's rule looks like:

SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0660", GROUP="plugdev"
  • Thanks for the reply, however instead of using Ubuntu, I managed rooting my tablet through a Windows VM. – Sasha Sep 21 '13 at 18:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.