This question is yet another one about problems with blank screens when trying to install Ubuntu (12.04.2) on a machine which uses UEFI Secure Boot. In my case, installing off of a DVD in an external drive.

I have already tried modifying the boot config according to the suggestions made in assorted thread (see -- partial -- list below), so I'm here to ask what can I try next?!

I am still hoping that there's a straightforward solution, though one post I saw (about problems with the Intel 3000 graphics card) does appear to suggest that I might be forced to use the command line install. If that it the case, I'd like to be confident that the problem can be fixed readily post-install.

Please bear in mind that I'm new to Ubuntu and Linux in general.

  1. Configurations tried so far, all starting off from:

    set gfxpayload=keep
    linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash --
    initrd /casper/initrd.lz

    I tried:

    • adding nomodeset (to the linux ... line)
    • adding nomodeset=1
    • replacing quiet splash with nomodeset=1
    • replacing quiet splash with nomodeset acpi=off
    • replacing quiet splash with nomodeset apic=off acpi=off
    • replacing quiet splash with nomodeset apic=off acpi=off drm_kms_helper.poll=0

    I even tried adding set gfxmode=1366x768 just after set gfxpayload=keep with the final permutation, but no joy. (I'm not even sure that could work?)

  2. Installed Wubi

    In an attempt to sanity check the DVD, I ran the Wubi install from Windows. It ran through fine and completed ok, as far as I could tell.

    Of course, I couldn't boot into Wubi as I was blocked by the \ubuntu\winboot\wubildr.mbr + 0xC000007B problem. So I just uninstalled it.

  3. My machine is an ASUS X502C with an Intel i3-3217 processor and an "Integrated Intel® HD Graphics 4000" card.

    The laptop was actually listed in the online catalog as an ASUS X501A, which appears to get the green light in ubuntu.com's certification list, and to be commented favourable on in the forums. (I assume that the stock of old machines ran out and they moved onto its successor. While the X502C is no doubt supposed to an improved version of the X401A, it isn't going to well for me so far...)

  4. I confirmed that it is using UEFI Secure Boot (Confirm-SecureBootUEFI returned True)

  5. The black, new style GNU Grub screen is the one that's displayed

  6. The main threads I've looked at so far:

    Plus this, which is a bit dense for me:


If you can't get it to work in EFI mode, try this:

  1. Disable Secure Boot in your firmware.
  2. Enable BIOS/CSM/legacy support in your firmware. (It can go by any of a number of names.)
  3. Boot the Ubuntu installer in BIOS/CSM/legacy mode. Verify that it's running in this mode by dropping to a shell and looking for the directory /sys/firmware/efi; it should not exist.
  4. Do the installation. When you're done, Windows and Ubuntu should both boot, but you'll need to select the boot mode by changing it in the firmware, or at least by using the computer's built-in boot manager.
  5. In Windows, install my rEFInd boot manager.
  6. Edit rEFInd's refind.conf file: Uncomment the scanfor line and ensure that hdbios is among the options.

If all goes well, when you reboot you should see a rEFInd boot menu with at least two options. One will boot Windows in EFI mode and the other should boot GRUB in BIOS mode; GRUB in turn will boot Linux. This is about as smooth as you can get a mixed EFI-and-BIOS dual-boot configuration to work.

Unfortunately, I can't guarantee that this will work at all. There are a number of potential problems with rEFInd's BIOS-mode support, and if the video problem isn't EFI-related, this method won't help at all.

  • I am having problems configuring my computer to boot in CSM mode; the BIOS setup utility will not let me edit the required option (I'm currently chasing up with ASUS.) – Andy Sep 3 '13 at 9:58
  • And before I continue, I have been looking more closely at the Intel side of things, and found one askubuntu.com question which seems to suggests that for Intel HD 4000 support I would be better off switching to Ubuntu build 12.10 or even 13.04. Does this make sense in my case?? askubuntu.com/questions/228118/… – Andy Sep 3 '13 at 10:05
  • I don't know about your video card specifically, but as a general rule, yes; newer releases are more likely to have better hardware support, particularly for newer hardware, than are older releases. – Rod Smith Sep 3 '13 at 15:16
  • I have just heard back from ASUS that the X502A does not allow you to enable CSM mode or disable Secure Boot unless a legacy operating system is present (which makes me wonder how it's supposed to get there?) They suggest I use the command line install (from the minimal DVD?) I now need to make a call on whether to (a) follow through with their advice (I would prefer an LTS release, but if 13.04 offers better driver support I guess I should go with it) or (b) look at getting the model of PC I thought I'd ordered so I can go the CSM route. So, is 13.04 stable enough?? (cf. LTS) – Andy Sep 3 '13 at 17:18
  • If the ASUS really doesn't let you disable Secure Boot except to run a BIOS/CSM/legacy OS RETURN IT NOW!!!!! Although you can use shim or PreLoader on such a computer, there can be significant hoop-jumping involved. Ubuntu theoretically support Secure Boot, but in practice there are often problems; and you might one day want to use another distribution, only to be hamstrung by the firmware. Manufacturers WILL make things worse in the future if we accept junk today. OTOH, I suspect that your ASUS tech was wrong, and there is a way to disable Secure Boot. – Rod Smith Sep 4 '13 at 0:56

In the BIOS,

Under the security tab, change Secure Boot Control to Disabled. Then under the boot tab change Launch CSM to Enabled.

Then with your install media (thumb drive or external optical) plugged in move that device to the top of your boot order, again from the boot tab in your BIOS.

Source: just did it on a Asus X502C and it works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.