My home server is on comcast internet so I'm successfully using the comcast smarthost to relay my email out to the web. However, all the emails I send back to the box bounce back to me as shown below and I can't find any clues in the logs.

Delivery of a message from you has exceeded the retry time:
From:    me@work.com
Subject: RE: not working

The following recipients could not be delivered:

I'm using a domain registration site to point myhost.ca at my IP address and I think I've got my MX record set correctly.
This site http://mxtoolbox.com/SuperTool.aspx says the following about my MX record.
Pref Hostname IP Address TTL
30 myhost.ca XX.XX.XXX.XXX 60 min

I've configured my router to forward the following ports to my ubuntu server:
POP 110
POPs 995
IMAP 143
IMAPs 993
SMTPs 465
SMTPs2 587

FYI the webserver and ssh access both work fine. Incoming email seems to be the only thing that isn't working.

From the local machine I can telnet to port 25 and 587 and "HELO myhost.ca" responds as expected. From any machine outside my house telnet won't connect to those ports and times out. I expect port 25 is blocked by comcast but I'm expecting 587 to be useable.

Can anyone suggest next steps for debugging?

thanks for reading!


It may be a case of blocked ports.

What is the output of /var/log/mail.log

If you are using a firewall maybe you should check any rules considering the ports in question.

For iptables a sudo iptables -L should output the current rules. If the ports are closed you can tell iptables to incoming traffic using:

sudo iptables -A INPUT -p tcp --dport PORT_NUMBER_HERE -j ACCEPT

For a complete HowTo about iptables check here

Also this is a very good tutorial on setting a mail server on Ubuntu 12.04 using Postfix, Dovecot and MySQL for virtual user mailboxes (personally tested on production server)


I had the same issue. but when I added my domain like to mydestination and also added my server ip address in mynetworks inside /etc/postfix/main.cf , thats do the trick for me. so like this:

mydestination = $myhostname, mydomainName, myuser.myuser, localhost.myuser, localhost,yahoo.com,gmail.com,google.com,mydomain.com
mynetworks = [::ffff:]/104 [::1]/128 My.server.ip.address

change the My.server.ip.address part to your server Ip address. and myuser to your ubuntu server username that you are currently logged in with. (off course the username parts should be there by default though).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.