My laptop worked perfectly util I initialized the build environment for Android. The GUI won't start. It looks like some kinds of graphics card problems. I tried to fix it but after trying a lot of solutions on the internet nothing worked. (I only know basic linux stuffs.) I've already reinstalled the OS. However, I still want to build the Android from source.

Any idea what might cause the problem? any workaround?

Here is the command that I used to initialize the build environment:

$ sudo apt-get install git gnupg flex bison gperf build-essential \
zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
libgl1-mesa-dev g++-multilib mingw32 tofrodos \
python-markdown libxml2-utils xsltproc zlib1g-dev:i386
$ sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so

My laptop model is asus u36sd. (https://help.ubuntu.com/community/Asus_U36SD) Thanks

Edit: Base on this, I guess libgl1-mesa-glx:i386 might cause the issue.

sudo apt-get install libgl1-mesa-dri:i386

The following packages will be REMOVED:
libgl1-mesa-dri-lts-quantal libxatracker1-lts-quantal ubuntu-desktop xorg
xserver-xorg-lts-quantal xserver-xorg-video-all-lts-quantal
The following NEW packages will be installed:
libdrm-intel1:i386 libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386
libexpat1:i386 libffi6:i386 libgl1-mesa-dri:i386 libllvm3.0:i386
libpciaccess0:i386 libstdc++6:i386
  • initialize build as given in this fourm askubuntu.com/questions/256487/… – Gur-I Oct 24 '13 at 15:33
  • 1
    Yes, I know exactly WHAT caused it (because it did it to me too) - the install of libgl1-mesa-glx:i386 wipes out most of X. WHY is another matter. – user258219 Mar 14 '14 at 14:02

You have uninstalled quite a few important packages including ubuntu-desktop and xorg. This is the reason why you have no GUI. Still you have a shell running.

Before rebooting, switch to first terminal CTRL+ALT+F1 Log on. Then run

 sudo apt-get install ubuntu-desktop xorg

Agree to remove libgl1-mesa-dri

| improve this answer | |
  • 1
    @Grzeqorz: How is one supposed to remove libgl1-mesa-dri wihtout also removing ubuntu-dekstop or xorg? Seems like they are dependencies. – Jordan Nov 12 '13 at 21:56

I had the same problem. Simply re-installing the desktop using sudo apt-get install ubuntu-desktop followed by a reboot worked for me.

| improve this answer | |
  • 1
    maybe with usage of the --reinstall modifier? – s3lph Jan 23 '14 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.