I have installed transmission, and i have added a torrent to it, now how will i be able to view the details of the torrents.

i have tried transmission-remote on local system.

m@m-170:/home/m/$ transmission-remote -n transmission:transmission -st

  Uploaded:   None
  Downloaded: None
  Ratio:      None
  Duration:   1 hour, 31 minutes (5478 seconds)

  Started 1 times
  Uploaded:   None
  Downloaded: None
  Ratio:      None
  Duration:   1 hour, 31 minutes (5478 seconds)

and when i view my transmission gui it is currently downloading

how can i see the status, current download and upload speed and also add and remove torrents


i have check an my default username and password is transmission so when i go here


and type username and password, i see the web interface of the transmission, but i dont see the current downloading in the gui.

is there a way in transmission command line, that i can check what is in my gui and its status of my torrents

  • 3
    Is transmission-remote -n user:pass -l not doing what you want? – moon.musick Aug 28 '13 at 17:02

I'm using transmission-remote-cli. It is a Curses interface communicating with the Transmission instance (locally or on the net) using the RPC protocol. Check the Debian package.

On server:

sudo apt-get install transmission-cli transmission-daemon transmission-common
mkdir /home/user/torrents
sudo chown -R debian-transmission:debian-transmission torrents

sudo service transmission-daemon stop

sudo vim /etc/transmission-daemon/settings.json

"download-dir": "/home/user/torrents",
"rpc-authentication-required": true,
"rpc-enabled": true,
"rpc-whitelist-enabled": false,

sudo service transmission-daemon start

On client

yaourt -S transmission-remote-cli
transmission-remote-cli -f ~/.trclirc --create-config
vim ~/.trclirc

password = transmission
username = transmission
port = 9091
host =

Start transmission curses interface with

transmission-remote-cli -f ~/.trclirc
  • doesn't work for me when I put the files inj user's home dir – chovy Aug 22 '18 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.