I have done a silly things. Some days ago I install dolphin in my Ubuntu 12.04. After that I was in love with dolphin for having thumbnail preview of folder with images inside. So, I thought of setting dolphin as a default file manager. So from the following link I found a solution: How to run Dolphin instead of Nautilus?

I have not followed the whole artical. Just used the first code:

sudo mv /usr/bin/nautilus /usr/bin/natilus.back && sudo ln -s /usr/bin/dolphin /usr/bin/nautilus

It makes my default file manager as dolphin. When I click to home folder launcher it now opens with dolphin.

Now I want to revert to Nautilus. But I am not getting any way to go back. But I thought if I change the upper code it may revert. So, I changed it with:

sudo mv /usr/bin/nautilus /usr/bin/natilus.back && sudo ln -s /usr/bin/nautilus /usr/bin/dolphin

And after that nautilus is not working. If I click home folder it also not working. If I write gksu nautilus in terminal it also not working after giving password. The only way that is left to access file manager is using dolphin. So, please help me. I need a solution. I need to make everything like before.

Now when I try to access mounted drive from launcher. It says:

Failed to execute child process "/usr/share/applications/nautilus.desktop" (Permission denied).

Please help me as soon as possible.


Here is what you did - each piece of code explained:

sudo mv /usr/bin/nautilus /usr/bin/natilus.back

You renamed the Nautilus program to "natilus.back". (You misspelled too unless you meant to call it natilus instead of nautilus.)


If that succeeded (which it did)...

sudo ln -s /usr/bin/nautilus /usr/bin/dolphin

Make a link called nautilus which will actually execute dolphin every time nautilus is called.


By executing this...

sudo mv /usr/bin/nautilus /usr/bin/natilus.back && sudo ln -s /usr/bin/nautilus /usr/bin/dolphin

... I think you renamed your link over your backed up program - nautilus (now the link) over natilus.backup. So now the nautilus program is gone. (I will stand corrected as I am not totally sure about that.)


What you should have done to reverse this was remove the link...

sudo rm /usr/bin/nautilus

...and rename the backup you made to its original name.

sudo mv/usr/bin/natilus.back /usr/bin/nautilus

(Again, assuming you did actually name the backup natilus.back instead of nautilus.back)


To fix, still remove the link you no longer need...

sudo rm /usr/bin/nautilus

...then remove and reinstall nautilus with apt-get.

sudo apt-get remove nautilus && sudo apt-get install nautilus

Hope that helps.

  • Alhamdulillah. Your answer solved my issue. Many many thanks to you Jack. Please pray for me so that I can understand this kind of command line interface. – Spiritual.Bird Aug 21 '13 at 19:23

If I understand correctly you want to revert back the changes, ok. Then just do:

sudo apt-get --reinstall install nautilus

Is impossible to revert the commands since you made two big mistakes, instead of following the answers you followed the question. Also you ran sudo mv /usr/bin/nautilus /usr/bin/natilus.back twice. The second one was totally unnecessary. If you wanted to revert it the correct command for both was:

sudo unlink /usr/bin/nautilus && sudo mv /usr/bin/nautilus.back /usr/bin/nautilus
  • Braiam, thanks a lot to you too. But as the first answer of Jack solved the problem, I have not tried yours one, but you guys are awesome, ubuntu community is too. Please keep up your support to the community. Please pray for me so that I can also understand linux, and be a power user of it. – Spiritual.Bird Aug 21 '13 at 19:25
  • Braiam's answers is more to the point. – Jack Aug 21 '13 at 19:45
  • @braiam,Just yesterday I have opened the askubuntu account, and this one is my first post in it, so I thought the first one above the list is the earlier one... lol to me. But thanks for answering first. – Spiritual.Bird Aug 21 '13 at 20:54
  • @Jack Yes, but you have figured it out that I am a novice. – Spiritual.Bird Aug 21 '13 at 20:59
  • @Braiam Thanks for remembering. I have ticked right to the anwser of Jack. – Spiritual.Bird Aug 21 '13 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.