I recently installed Lubuntu but I have a problem with Adobe Flash Player. I always see something that looks like this when I open a video:

(source: hostingpics.net)

The video is small, grainy, and is green and purple.

I tried to reinstall Flash and to test it in multiple browsers without success.
I installed an older version of Flash but no result.

[0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
    Subsystem: Hewlett-Packard Company D530 sff(dc578av) [103c:12bc]
    Kernel driver in use: i915
  • Cannot find the intel driver installer. It is not under the menu. How can I locate it? Thanx – user265221 Apr 4 '14 at 6:33
  • @watjilpa It would have been better if you asked this question separately. – Hakim Jul 19 '14 at 2:36

This seems to be a problem on some computers with Intel graphics cards and Lubuntu. Only follow this if you're using an Intel graphics card.

I had the same exact problem with my kids laptop running Lubuntu 13.04. I installed, and re-installed flash, tried an older version of flash, and other things, and nothing seems to work. All I had to do was to download and install the latest graphics driver. In my case it wan an Intel built in graphics adapter.

Note: I have Lubuntu install updates, and other restricted during installation, and I didn't have to do anything with installing flash.

Only Intel

Download this driver from Intel. Go for the latest version but make sure that you get the right architecture (32 vs 64 bit). You can check this in a terminal by running uname -i. If it says x86_64, you want the 64 bit version, otherwise assume you need the 32 bit version.

Then to install it, just press Control+Alt+T on your keyboard to open Terminal. When it opens, navigate to the Downloads folder, and run the command(s) below:

sudo dpkg -i <file_name>.deb

Once installed, go under the menu, and click on the Intel driver installer. I believe it under the accessories menu, but I'm not sure, just look for it. Once it download the needed files, reboot the system, and see.

  • I have the newest drivers... But can you give me more information? – Hakim Aug 21 '13 at 11:23
  • What graphics adapter do you have? Have you installed Lubunutu Restricted Extras? – Mitch Aug 21 '13 at 11:27
  • A VGA one, I have VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02) Subsystem: Hewlett-Packard Company D530 sff(dc578av) [103c:12bc] Kernel driver in use: i915 – Hakim Aug 21 '13 at 11:34
  • look at the added info in the answer. – Mitch Aug 21 '13 at 11:43
  • @Mitch, your solution helped someone else too! – user25656 Aug 25 '13 at 2:18

Try this from your terminal, first remove old unnecessary package :

sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper

Reinstall flash :

sudo apt-get install --reinstall adobe-flashplugin
  • Do you have made a mistake when you wrote 'adobe-flashplugin' ? Because I get this message: 'Package adobe-flashplugin is not available, but is referred to by another package.' Thank you. – Hakim Aug 21 '13 at 10:51
  • @حكيمالفيلسوفالضائع Enable the Canonical Partner repository in the software sources settings from within the software centre. – gertvdijk Aug 21 '13 at 11:20
  • Even if I do it, it doesn't find it... I enabled all the repositories. – Hakim Aug 21 '13 at 11:33

protected by Community Jun 6 '14 at 12:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.