I installed Ubuntu on a pc with Windows 8 preinstalled.

After installation Grub showed Ubuntu entries and Windows 8 Boot Manager (or something similar), selecting it I got:

file path /ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/HD(2,e1800,82000,963b540a6178e211,8d,38)/File(\EFI\Microsoft\Boot)/File(bootmgfw.efi)/EndEntire

error: cannot load image.

After that I run boot-repair with the default options.

This is the file it generated: http://paste.ubuntu.com/6005571

And this grub entries:

  • Ubuntu
  • Advanced options for Ubuntu
  • Windows UEFI bkpbootmgfw.efi
  • Windows Boot UEFI loader
  • EFI/toshiba/Boot/bootmgfw.efi
  • Windows Boot Manager (UEFI on /dev/sda2)
  • System setup (Bios menu)

The four about Windows 8 all give a similar error message:

Windows UEFI bkpbootmgfw.efi

file path /ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/HD(2,e1800,82000,963b540a6178e211,8d,38)/File(\EFI\Microsoft\Boot)/File(bootmgfw.efi)/EndEntire

error: cannot load image.

Windows Boot UEFI loader

file path /ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/HD(2,e1800,82000,963b540a6178e211,8d,38)/File(\EFI\Microsoft\Boot)/File(bkpbootx64.efi)/EndEntire

error: cannot load image.


file path /ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/HD(2,e1800,82000,963b540a6178e211,8d,38)/File(\EFI\toshiba\Boot)/File(bootmgfw.efi)/EndEntire

error: cannot load image.

Windows Boot Manager (UEFI on /dev/sda2)

file path /ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/HD(2,e1800,82000,963b540a6178e211,8d,38)/File(\EFI\Microsoft\Boot)/File(bootmgfw.efi)/EndEntire

error: cannot load image.

How can I fix this?


Following Rod Smith answer I tried wit rEFInd from an USB flash drive.

It shows two Windows icons, one of which work (the other gives an error, it's the one that says Probabbly Grub).

The working one is: Boot Microsoft EFI boot (Boot Repair backup) from 256MiB FAT Volume

enter image description here

So I was able to boot into Windows, now how can I fix this so that I don't have to use rEFInd?

And how can I remove rEFInd from my pc (it shows also after removing the usb flashdrive from the pc)?

  • Do consider adding yourself to bug 1091464.
    – ubfan1
    Aug 30, 2013 at 23:58

2 Answers 2


My solution to fix the problem is as follows:

Go to bios menu by selecting system setup. Press right arrow to change tabs until you come across secure boot. if it is enabled then disable it. If this works then you might want to disable fast startup as well once you're in Windows.

However disabling fast startup is completely optional. Windows will boot properly even if it is enabled. fast startup should be disabled for those who use files on both Windows and Ubuntu. Or else you might get an Unable to mount the drive error.

  • 1
    This has worked for me. I'd link this answer to an instruction on how to disable your fast startup on Windows, but that depends on which version of Windows you're running, so whoever has this problem please google it. Dec 12, 2015 at 2:04

Try preparing a USB flash drive or CD-R with my rEFInd boot manager. (Download links for both types of media appear on the download page I've just referenced.) Boot from it. Chances are it will give you two Windows icons with different descriptions. If you're able to boot to Windows from rEFInd using any icon, try installing rEFInd in Ubuntu using the Debian package file. If rEFInd doesn't work or if it works partially but has its own problems, post back with details. (You might want to edit your original question, especially if the problem is complex.) Note that you can adjust the entries that rEFInd shows by cleaning out unwanted boot loaders (files with .efi extensions) from the /boot/efi/EFI directory tree (in Linux) or by editing /boot/efi/EFI/refind/refind.conf and uncommenting and adjusting the dont_scan_files and/or dont_scan_dirs options.

  • If rEFInd works, then I recommend you just keep using it. As you've discovered, GRUB is finicky and difficult to configure and debug, so the intent of my answer was to provide an alternative to GRUB.
    – Rod Smith
    Aug 20, 2013 at 20:06
  • ok... i could keep it but I would like at least to remove Grub since it's an added layer with another options to select Aug 20, 2013 at 20:13
  • and what will happen with new kernels? does refind update itself automatically? because i've not installed anything but only used the usb driver Aug 20, 2013 at 20:14
  • You can certainly remove GRUB. Deleting the GRUB package (with apt-get, synaptic, or whatever) probably won't delete the GRUB binary on the ESP; for that, you should manually delete the /boot/efi/EFI/ubuntu directory tree. Alternatively, as noted in my original answer, you can set the dont_scan_files or dont_scan_dirs options in /boot/efi/EFI/refind/refind.conf to leave GRUB installed but hide it from the rEFInd menu. rEFInd scans for EFI boot loaders and kernels on every boot, so it will automatically detect new kernels.
    – Rod Smith
    Aug 20, 2013 at 23:51
  • Im having the exact same problem it seems with Ubuntu 14.10 running on a Lenovo T440P. At least I get the same error messages and have a similar result from Boot-Repair. Is there any solution to this problem that includes keeping Grub as the boot manager? Im a bit reluctant to remove it because of possible additional errors. Jan 13, 2015 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .