3

I've been trying to setup an Ubuntu 12.04 workstation on a Hyper-V virtual machine (MS Windows Server 2008 R2) and I need some help with the mouse driver.

The mouse responds fine in general: the cursor's moving, left/right click works OK and also when I press the wheel windows are changing and tabs are closing.

Everything EXCEPT scrolling: Then nothing happens, except that the cursor's appearing on the upper left corner of my VM desktop and when I move the mouse it appears back where it was.

Can someone guide me how to solve this? It gets really annoying... Thanks!

1

As it turns out, this is a bug with Windows Server 2008 r2 Hyper-V per RedHat:

https://bugzilla.redhat.com/show_bug.cgi?id=872519

Their research shows the problem is fixed in server 2012.

  • "Supported Guest Operating Systems This version of Linux Integration Services supports the following guest operating systems: Red Hat Enterprise Linux 5.7, 5.8, 6.0-6.3 x86 and x64 CentOS 5.7, 5.8, 6.0-6.3 x86 and x64" Are you sure I can apply them to Ubuntu 12.04? – lephleg Aug 20 '13 at 13:06
  • baudlabs.com/… Worked for them :) – Colyn1337 Aug 20 '13 at 13:09
  • administrator@gnorasis-ununtu:~/linuxic/RHEL63$ ./install.sh Installing the Linux Integration Services for Microsoft Hyper-V... ./install.sh: line 28: rpm: command not found Kmod RPM installation failed, Exiting. Well it seems that the installing script failed.. :/ – lephleg Aug 20 '13 at 13:22
  • In the SxS (step by step) it mentions the services should be built in (since 10.10). The SxS includes instructions on how to activate the IC's. I edited my answer to match. – Colyn1337 Aug 20 '13 at 13:29
  • Thanks for the edit. I've also tested that earlier so everything seems to be running fine (i.imgur.com/e3sIxyj.png) but still no scrolling.. – lephleg Aug 20 '13 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.