5

When I plug my FiiO E7 USB Audio DAC & Amp in Ubuntu 13.04, it is recognized as Audio DAC but only via the Analog Output port.

I have to log-out and in again before the USB Audio DAC Digital Output (S/PDIF) comes available in Sound settings, which has much better quality.

How can I enable the Digital Output manually, so I don't have to logout?

  • This answer to a similar question suggests sudo alsa reload followed by sudo killall pulseaudio, and then plugging the FiiO DAC device. Does this work for you? (In my case, with a FiiO X3, I'm still only seeing DAC Analog Stereo, and no digital port...) – landroni Feb 14 '15 at 21:35
  • This other answer proposes an interesting VLC-based workaround, but I'm not yet sure if it makes a real difference (at least FiiO X3 keeps displaying 44kHz/24bits, which I suspect effectively means Analog Output port). – landroni Feb 14 '15 at 22:24
4

To enable digital output on a FiiO X3 without ending session you need to kill PulseAudio as suggested in How to I get the right Pulseaudio profiles to show up without restarting Pulseaudio?:

pulseaudio -k

Then I can see the device FiiO USB Audio Class 2.0 DAC Digital Stereo (IEC958), while PulseAudio Mixer reports the Digital Output (S/PDIF) port.

I'm not convinced yet that using the Digital Output (vs the Analog Output) changes audio quality that much, though... And the X3 still displays 48kHz/24bits, whichever device is selected, so I suspect that the OS still downsamples the whole thing before passing it to the device...

1

You need to connect your E07 before you turn on your computer. It is that easy. Enable Digital Output for E07 in Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.