I was given a HP Probook 4720s as a work laptop, over the last 2 years I've predominantly used Ubuntu as my OS for work and home, but recently have needed to use Windows 7 as it controls the fans correctly.

I am now at the point where I want to try and resolve this issue. I haven't asked a question before for help as I can nearly always fulfill my queries with a search engine.

So here are the outputs from lspci/lsusb/lsmod not sure what is required so it's a starting point and also a link to the hardware from hardinfo.

Hardinfo output, LSPCI Output, LSUSB and LSMOD

It has been suggested to me that Ubuntu one sync daemon could have been the issue but I've tried quitting this to no avail, I have also tried using the CPU Demand Frequency to it's lowest setting 933mhz but the fans still keep going.

/proc/acpi/fan is totally empty which I am guessing is that the fan hasn't been detected.

The sensors program detects temperatures but does not detect the speed of the fans.

andy@lappy:/proc/acpi/fan$ sensors
Adapter: Virtual device
Temp1: +56.0°C  (crit = +127.0°C)                  
Temp2: +0.0°C  (crit = +128.0°C)                  
Temp3: +0.0°C  (crit = +128.0°C)                  
Temp4: +38.0°C  (crit = +127.0°C)                  
Temp5: +0.0°C  (crit = +128.0°C)                  
Temp6: +27.0°C  (crit = +128.0°C)                  
Temp7: +64.0°C  (crit = +128.0°C)                  
Temp8: +46.0°C  (crit = +128.0°C)                  
Temp9: +51.0°C  (crit = +128.0°C)                  
Temp10: +59.0°C  (crit = +128.0°C)    

andy@lappy:/proc/acpi/fan$ acpitool -f
Fan: not available

I'm guessing it's an ACPI issue but from lack of good results / Google foo I cannot find a solution.

I have tried a few fixes from the ubuntu forums which I am failing to find links for at the moment but none of them have been useful yet.

Just to add this happened from a clean install so no unruly processes as mentioned in other posts.

Open to try just about anything, I will reinstall if I need to.

  • As after James had fixed my hyperlinks issue I can't edit with out destroying the links I will add that I have also updated the BIOS to the newest version as well from the HP Site. – Andy Partington Apr 4 '11 at 12:32
  • Any news on this issue? Are you happy with the Notebook under Ubuntu? I'm considering to buy one, so I would really appreciate your feedback! Thanks! – user14518 Apr 18 '11 at 15:29

Have you checked whether you use the proprietary ATI driver (flgrx package)? The open source radeon driver is known to have poor power management support.


I found this:


Try it for me (probook 4530s seems it fixed)

  • For the HP probook 4330s - which is similar - it doesn't. – Dirk B. Aug 11 '12 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.