9

Have reinstalled Ubuntu on my web dev server. On the old one I had an smbfs share setup to access a share over the local network to other Ubuntu boxes. It was setup using the following and worked fine - http://ubuntuforums.org/showthread.php?t=288534

This time round I am using cifs-utils instead of smbfs, but I presume this is fine?

Upon reinstalling the server I have been having issues making the files writable. Its mounted ok, and when from my local machine I ls -l it shows me write permissions (although from my local user), but when I goto create or save over a file it gives me a no permissions error

Here is the line in my /etc/fstab. I had to make one change to be able to mount, and I added the ,sec=ntlmv2 option, without which I was getting mount error(13)

//192.168.0.40/webserver    /media/webserver        cifs    credentials=/root/.smbcredentials,sec=ntlmv2,iocharset=utf8,file_mode=0777,dir_mode=0777,uid=1000,gid=1000 0 0

and my credentials file (unchanged from when it was previously working)

username=melon
password=xxxxxxxxxxxx

How can I fix it so that I have write permissions on my mount?

4

Make sure you have the following line in your /etc/samba/smb.conf file on the server:

writeable = yes

Hopefully that will enable write access to the share.

6

In my case solution was to add noperm option on the fstab entry

  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Aug 23 '15 at 10:48
1

As Mario Mastrorilli already mentioned form me the noperm option in the fstab worked. Here is the requested HowTo (David Foerster)

  1. Just open /etc/fstab:

     $> sudo nano /etc/fstab
    
  2. Add a line like that:

    //abc-fs/folder/  /media/mountpoint                 cifs    credentials=/root/.smbcredentials,iocharset=utf8,noperm       0       0
    
  3. Mount

    $> sudo mount -a
    
  • Not at all! See Comment from David Foerster in the answer from Mario Mastrorilli. Just want to summarize all facts properly. – Marcel Lange Nov 10 '15 at 15:28
  • From the manpage (linux.die.net/man/8/mount.cifs) noperm Client does not do permission checks. This can expose files on this mount to access by other users on the local client system. It is typically only needed when the server supports the CIFS Unix Extensions but the UIDs/GIDs on the client and server system do not match closely enough to allow access by the user doing the mount. Note that this does not affect the normal ACL check on the target machine done by the server software (of the server ACL against the user name provided at mount time). – Rich Aug 29 '17 at 6:17
0

In your server add following in file /etc/samb/samb.conf:

read only = no

hope this will work.

  • Do you mean /etc/smb/smb.conf of /etc/samba/smb.conf? – Volker Siegel Sep 25 '14 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.