I need to turn off the backlit keyboard on my Sony Viao, with 64 bit Ubuntu 13.04. I'm prone to migraines, and the lights really bother my eyes.

I've tried several posted solutions, none work. (although one worked on Ubuntu 12.xx 32bit)

Here are some of the threads I've tried:

These don't work:

echo 0 > /sys/devices/platform/sony-laptop/kbd_backlight

     the directory exists, but not the file.

This looked promising:

sudo modprobe -v sony-laptop
modinfo sony-laptop

But then, neither of these worked:

sudo modprobe -v sony-laptop kbd_backlight=0
sudo rmmod -v sony-laptop; sudo modprobe -v sony-laptop kbd_backlight=0

I guess I'll try this anyway, and reboot:

echo "options sony-laptop kbd_backlight=0" | sudo tee /etc/modprobe.d/sony-laptop.conf

I'll let you know if it worked.

  • This works: echo "options sony-laptop kbd_backlight=0" | sudo tee /etc/modprobe.d/sony-laptop.conf – Debbie V Feb 9 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.