I know this question has been asked a lot, but I didn't find an answer here.

Ubuntu 12.04.2 64-bit was installed offline just a few hours ago on one ext4 partition, and a swap partition was also created.

The installation went fine, but now I can't get into Ubuntu.

I want to use the Windows 8 boot manager, to select between the two operating systems, so I downloaded EasyBCD and added an entry for Ubuntu.

The entry shows up in the boot manager menu, but when I click on Ubuntu I get the following message:

NST/AutoNeoGrub0.mbr not found

I tried enabling/disabling Secure Boot and restarting, but it still shows that error message.

Boot repair summary Latest boot repair summary

Out of desperation I tried to find a solution myself and reset the BCD configuration via EasyBCD. Now Grub boots fine and Ubuntu too, but I can't boot Windows 8 anymore.

Then, for whatever reason after installing all updates for Ubuntu, I restarted the system and now I can't boot into Ubuntu. Only via Live CD and the old Linux entry can I start it.

  • Do you mean you reset the BCD config and re-add the entries, or do you mean you reset the BCD config and added zero entries after that? – Pacerier Apr 26 '15 at 20:55

First, the last I heard, EasyBCD was useless for managing a Windows/Linux dual-boot on an EFI-based computer, so I recommend you stop trying to use it.

Second, given your current situation (as specified in your Update), there are several possible solutions. The two easiest are:

  • Run Boot Repair. I know you said you've tried this, but it's not clear if you've tried it since the change to the situation in which you can boot Ubuntu but not Windows. If not, it's worth trying Boot Repair again.
  • Install my rEFInd boot manager. Installing the Debian package in Ubuntu is the easiest way to do this, although it's a bit safer to try to use the CD-R or USB flash drive version first, and install the Debian package only if the CD-R/USB flash drive version can boot both your OSes. rEFInd is less finicky about booting Windows than is GRUB, so it might fix the problem.

If neither of these methods fixes your problem, please post back with a fresh URL for your latest Boot Repair run.

Update: First, be sure that Secure Boot is disabled.

Next, are you able to boot via the rEFInd USB flash drive or CD-R image? If so, try this:

  1. Boot to Linux.
  2. Open a Terminal window.
  3. In the Terminal, type sudo efibootmgr to find all your current boot entries.
  4. In the Terminal, type sudo efibootmgr -b 0000 -B. This deletes the Boot0000 entry.
  5. Repeat step #4, replacing 0000 with each Boot#### number identified in step #3. (Your Boot Repair output suggests you'll have 0000, 0001, 0002, 0004, 0005, 0007, 0008, 2001, 2002, and 2003.
  6. Type sudo efibootmgr -c -p 2 -l "\EFI\ubuntu\grubx64.efi" -L "Ubuntu". Note the backslashes used as directory separators.
  7. If you've installed rEFInd to the hard disk after running the last Boot Repair, type sudo efibootmgr -c -p 2 -l "\EFI\refind\refind_x64.efi" -L "rEFInd".
  8. Reboot.

If all goes well, rEFInd should pop up, or at least GRUB, and you should be able to boot both Linux and Windows.

If the rEFInd CD-R or USB flash drive doesn't work, you could try the same from a Linux live CD that's booted in EFI mode.

  • Your answer is appreciated, thanks. I ran Boot Repair and updated the Boot repair summary. Still no luck. Also check out Update 2. Installing the debian rEFInd debian package did not work. – Christian Heinrichs Aug 19 '13 at 0:13
  • 1
    See my updated response. – Rod Smith Aug 19 '13 at 15:20
  • I don't know how to thank you. After following your method (except step 7) combined with bootrec /rebuildbcd from the rescue cmd I am able to boot Windows again. But Ubuntu still shows a black screen with a blinking symbol. As soon as I have 15 points I am going to upvote your answer. This is the least I can do. – Christian Heinrichs Aug 19 '13 at 16:03
  • Thanks to oldfred at ubuntuforums it was found out, that the fglrx driver caused Ubuntu not to boot even after your solution. Ubuntu is now working, even though the graphics driver is kind of broken. Thank you for your great answer, which led to both OS being functional again. – Christian Heinrichs Aug 23 '13 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.