I'd like to be able to disable the Ubuntu splash screen that I see on boot with the indicator meter of progress, and replace that with a text-only readout of the boot up process (such as you can get by hitting the esc key during the splash screen). Is this possible?

I am not asking to disable X and get to text-only login, I"m asking how to deactivate the "Ubuntu" loading screen with the dots, so that I can see text output from the boot process - processes being started, kernel messages, etc. When I wrote this question I was not asking how to disable X altogether, only the boot splash screen.


2 Answers 2


Yes. Edit /etc/default/grub (using sudo nano /etc/default/grub), and remove the "quiet splash" from the Linux command line:

Here's what it looks like by default:


Make it look like this:


After this run sudo update-grub2

Also from the GRUB menu, if you want to do this temporarily, you can hit E on a line to edit it, then Ctrl+X to boot the kernel line.

Make sure you don't have plymouth-theme-ubuntu-text package installed.

  • 6
    In addition to this, if you want to see the kernel startup messages you'll probably want to remove the "quiet" boot option too. Commented Apr 4, 2011 at 4:14
  • 4
    This worked. I wanted the kernel startup messages too, so by removing the "quiet" option too, it did what I want it to do. :)
    – Thomas Ward
    Commented Apr 4, 2011 at 4:52
  • 4
    +1 for pointing to the plymouth-theme-ubuntu-text package. (Check if you have it using dpkg -s plymouth-theme-ubuntu-text. If you want to remove it you can use apt-get remove plymouth-theme-ubuntu-text)
    – Wumms
    Commented Dec 15, 2015 at 18:44
  • 25
    Why would I want to remove plymouth-theme-ubuntu-text? What's this package's role in this? Doesn't it work if I don't? Could you give us some more context? -- In Xenial Xerus Lubuntu removal of that package would uninstall lubuntu-core and lubuntu-desktop, which seems pretty bad. (So it would be nice to avoid that.)
    – zrajm
    Commented Apr 30, 2016 at 13:59
  • 2
    "Command 'gksu' not found, did you mean: command 'ksu' from deb heimdal-clients (7.7.0+dfsg-1ubuntu1) command 'ksu' from deb krb5-user (1.17-6ubuntu4) command 'gosu' from deb gosu (1.10-1) Try: sudo apt install <deb name>" Commented Oct 18, 2020 at 15:25

So, I couldn't get this to work in Ubuntu 16.10 of 17.04. I used grub-customizer as well as editing the /etc/default/grub file directly (and using update-grub2 after). All the other things I could find had the same answer, remove quiet splash.

As it worked on a 16.04 system, I decided to compare the grub.cfg files and found an entry in the 17.04 grub.cfg file which said "vt.handoff". I found the following entry on this parameter; What is vt.handoff=7 parameter in grub.cfg?

Eventually I edited the grub.cfg file (which you shouldn't do because thats whatts update-grub2 is for, it will generate the grub.cfg file), but this seemed to work!

ps. removing plymooth did nothing on my system, so I added it back in.

  • 3
    What exactly did you change in which file? You mention grub.cfg (probably /boot/grub/grub.cfg) and vt.handoff but you don't specify what you did about it. FYI, if you did what I think you did, that change can be done better in /etc/grub.d/10_linux plus an invocation of update-grub. Commented Apr 23, 2017 at 10:53

Not the answer you're looking for? Browse other questions tagged .