I have a weird issue with Unity, it just stopped showing applications in the unity dash search menu.
I can't launch application unless I run them from the terminal.

I have tried to force unity re-installation with no success, and I could not find any other information regarding to this issue. Prior to full re-installation (I prefer not to, since my disk is encrypted) I am seeking for help. (I am a developer and would love to help with more information as needed).

An image

An image to applications is shown like this, when looking at Ubuntu dash search feature.

  • 1
    I think you're talking about the Ubuntu dash search engine. You can upload a picture and leave only a link to it. – Gediminas Jeremiah Gudelis Aug 18 '13 at 15:20
  • ok - Thanks, this is the link to the image link – Moshe Beeri Aug 19 '13 at 7:46
  • Searching for applications missing in dash, I got to this post I re installed unity-lens-applications and unity-lens-files and log out, but nothing had changed, any idea?? – Moshe Beeri Aug 19 '13 at 7:57
  • trying this as well mv ~/.local/share/zeitgeist ~/.local/share/zeitgeist.bak – Moshe Beeri Aug 19 '13 at 8:20
  • That did not help either. is there a way to re-install the whole unity package? – Moshe Beeri Aug 19 '13 at 8:30

Try to remove and re-install unity-lens-applications

sudo apt-get purge unity-lens-applications    
sudo apt-get install unity-lens-applications 

Edit: Log off & login. If doesn't work restart your system (see comments)

  • 1
    10x but it did not helped :-( Still can not see applications in dash! – Moshe Beeri Aug 29 '13 at 14:35
  • 1
    Any other suggestions? – Moshe Beeri Sep 2 '13 at 9:46
  • 2
    @rpadovani Just to say! Your tip work for me. But you need to restart your system after apply. Thanks for save my day! ;) – deepcell Apr 12 '14 at 13:27
  • I had this same problem. Your solution worked for me. Thanks!! – Matt Caswell Oct 26 '14 at 21:25
  • Worked for me, Ubuntu 14.04LTS – Bryce Nov 12 '17 at 6:32

Delete the .cache directory from home folder, logout and login again. It worked for me.

  • 1
    Thanks, But I already reinstalled the system. – Moshe Beeri Jan 20 '14 at 7:51
  • 2
    In case you encounter the same issue again this should help you. – anurag-jain Jan 21 '14 at 7:16
  • This worked for me – Luis Lobo Borobia Nov 18 '14 at 22:19
  • 2
    deleting ~/.cache/unity* worked for me – isalgueiro Aug 18 '15 at 16:29

I finally found out why the installed Applications were not showing up. Check for Filters options while searching and select the Applications button.

Mine was not selected so it was listing due to filters applied.



This command will restart zeitgeist daemon which sometimes fails to start and unity dash does not showing applications

sudo zeitgeist-daemon --replace
  • @damadam do you understand now? – Andrey Izman Nov 25 at 9:47

I had this problem. To solve it i deleted the recent files I had downloaded that were not on the software centre (i.e livewallpaper and the files related), used 'sudo apt-get autoremove' and then 'sudo reboot'.


Had this problem after unticking in Unity Tweak Tool > Web Apps > Preauthorized domains > Amazon
Reverted to default and got search working again

Not the answer you're looking for? Browse other questions tagged or ask your own question.