2

In order to eliminate some of the permissions obstacles I keep finding, I decided to make it easier on myself. I did

$ sudo chmod 755 -R /usr

If I knew 10 hours ago what I've learned in researching this, I wouldn't have used that command. I tried this first

$ chmod 755 -R /usr

That resulted an a large number of these:

$ chmod: changing permissions of ‘/usr/dir/file’: Operation not permitted

I tried another sudo command, and that one returns:

effective uid is not 0, is sudo installed setuid root?

Is there a way to reverse this without a clean reinstall? All I've done for the last 8 or 9 days is to read, configure software, and try to learn how to use the terminal, and I don't exactly look forward to starting that process again, even if not quite back to the beginning.

4

Not really. It's technically feasible, but a clean reinstall will be easier to fix this kind of issue.

If you really want to go the hard way, you should boot a live CD and reinstall sudo on your installation. Then reboot and sudo should be working again, allowing you to reinstall all your broken packages, etc.

| improve this answer | |
  • 3
    Plus, anything besides reinstalling runs the risk of not fully fixing the problem, and being unpleasantly surprised when things don't work right later. – Eliah Kagan Aug 18 '13 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.