16

I have a hard disk of 320 GB on ubuntu 12.04 64-bit.
2 drives of my hard (sda7 and sda8 of ext3 type) cannot be mounted.

output of sudo mount /dev/sda7 /home/newfolder -t ext3 :

mount: special device /dev/sda7 does not exist

/dev/ contains the following:

 sda   sda1   sda5   sda6

but GParted shows sda7 and sda8: GParted

output of blkid:

/dev/sda1: UUID="a898f3ad-11d9-4dbb-9ea8-71a819dc8f70" TYPE="ext4" 
/dev/sda5: UUID="998c7c6f-5ff8-426c-83d4-1a309b7cdc4f" TYPE="swap" 
/dev/sda6: UUID="da0460d0-714e-40ae-b88b-a0deca87087c" TYPE="ext4" 
/dev/sdb1: LABEL="FLASH DRIVE" UUID="8A24-B5CD" TYPE="vfat"

output of fdisk -l:

Disk /dev/sda: 320.1 GB, 320071851520 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625140335 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x17ea17ea

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      194559       96256   83  Linux
/dev/sda2          196607   625121279   312462336+   f  W95 Ext'd (LBA)
/dev/sda5          196608     8007679     3905536   82  Linux swap / Solaris
/dev/sda6         8009728    61431807    26711040   83  Linux
/dev/sda7        61432623   337911209   138239293+  83  Linux
/dev/sda8       337911273   625121279   143605003+  83  Linux

output of cat /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda8 during installation
UUID=da0460d0-714e-40ae-b88b-a0deca87087c /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=a898f3ad-11d9-4dbb-9ea8-71a819dc8f70 /boot           ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=998c7c6f-5ff8-426c-83d4-1a309b7cdc4f none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

output of ls /dev/mapper :

control
  • Try to create a mount point. Do not try to mount a partition under the whole /home . sudo mkdir /home/mydevice/ and sudo mount /dev/sda7 /home/mydevice – NickTux Aug 18 '13 at 4:43
  • I tried it, but ... – Dariush Aug 18 '13 at 5:04
  • Read the answers here and give us the results of cat /etc/fstab – NickTux Aug 18 '13 at 17:37
  • output of cat /etc/fstab was added. – Dariush Aug 19 '13 at 3:53
  • Can you add an entry in /etc/fstab and see what happens ? Try it. /dev/sda7 /home/mydevice/ ext3 defaults 0 2 . Also an important thing here might bee that blkid didn't show a UUID for /dev/sda7. Can you check that Gparted has a UUID number for this partition ? – NickTux Aug 19 '13 at 12:59
10

Did you re-partition that disk recently? That's the only thing that comes into my mind that could cause the kernel's understanding of the partition layout to differ from fdisk's.

If so, you need to tell the kernel to re-read the partition table with

sudo blockdev --rereadpt

(This used to be sfdisk -R, but sfdisk dropped -R in version 2.26.)

This can fail (with an error message) if you have any of the partitions of that disk already mounted. Unmount them and try again. Sometimes that's not possible (e.g. when your root partition is on the same disk), and you have to reboot instead.

(There is actually a way to force the kernel to re-read the partition table, which ought to be safe enough if you didn't change the sizes or positions of any of the mounted partition, but I don't remember the exact command line. I think it involves partx or kpartx.)

| improve this answer | |
  • sfdisk has no -R option... – Calmarius Mar 15 '18 at 14:18
  • 2
    @Calmarius: thank you! I've updated the answer to use blockdev --rereadpt like the sfdisk manual page recommends. – Marius Gedminas Mar 15 '18 at 15:56
  • Thanks, this worked for me when attempting to mount an old hard drive. – Ben Davis May 14 '18 at 0:38
5

Check lv status:

lvscan

check if the INACTIVE same as what you are missing.

To fix do vgchange:

vgchange -ay
| improve this answer | |
0

I tried with the accepted solution but it didn't fix the problem. The problem appeared after i deleted the partition "A" and i tried to mount the partition "B" in the same folder that was the mount point of "A". The OS was trying to reserve it to a death partition, so i edited the etc/fstab file and changed the mount point of "A" (there still was the line) with another one, and after rebooting all worked good. Maybe you could delete the entire line of the death partition, but i don't know...

To edit the partition:

sudo nano /etc/fstab

and i changed:

/dev/disk/by-uuid/YOUR-UIID path/to/mount/point auto uid=1000,rw,umask=111,dmask=000 0 0

with:

/dev/disk/by-uuid/YOUR-UIID UNUSED/path/to/mount/point auto uid=1000,rw,umask=111,dmask=000 0 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.