0

I have the newest flash player, but I cant get it to work on the website pogo.com. it says: Your Adobe Flash Player is out of date

No need to panic, you just need the latest version of Adobe Flash Player to play this game. Please visit Adobe.com to update your version now.

Update Adobe Flash Player

Still experiencing issues? Check out Adobe's Flash Troubleshooting Guide

I am very new to linux, so this is probably an easy fix, but still need help! So please help! :)

1

Sorry there is no fix for this. The latest Flash version provided by Adobe for Linux is 11.2. And pogo.com requires >11.7

As a workaround you could install a Windows version of e.g. Firefox in Wine or in a VM and use Flash for Windows with that. But that's quite ugly. I'd rather look for alternative websites/games.

Edit: Install Chromium with Pepper Flash

Open a Terminal with CTRL+ALT+T and type:

sudo add-apt-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install chromium-browser pepflashplugin-installer
echo ". /usr/lib/pepflashplugin-installer/pepflashplayer.sh" | sudo tee -a /etc/chromium-browser/default

Now open Chrome and go to chrome://plugins. If everything was correct you should see now Adobe Flash Player - Version: 11.8.XXX

  • Is there any indication of when Adobe will catch up with 11.7? And none of the extensions or addons in any of the browsers would work? – ScooterKat1231 Aug 18 '13 at 3:23
  • unfortunately never. Look at czapa_ols answer. I'm not sure about Chrome. A short test here with Chromium came up with the same error message. – Germar Aug 18 '13 at 3:31
  • Where can I get the pepper-based flash player...this is what I got when I researched it on adobe website...helpx.adobe.com/flash-player/kb/find-version-flash-player.html – ScooterKat1231 Aug 18 '13 at 3:33
1

First you should check if flash player is properly installed:

sudo update-pepperflashplugin-nonfree --status

In browsers webkit engine based like Opera, only most appropriate way to flash player work is using PPAPI flash player interface supported by default in multiverse repository in Ubuntu, not adobe-flashplugin, full description how to do that is here. There is no need to install alternative repository like shown above.

0

Short answer, easy fix: switch to google chrome.

Long answer: As of february 2012 Adobe no longer provides new releases of Flash Player for Linux after version 11.2.

From http://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html

For Flash Player releases after 11.2, the Flash Player browser plugin for Linux will only be available via the “Pepper” API as part of the Google Chrome browser distribution and will no longer be available as a direct download from Adobe. Adobe will continue to provide security updates to non-Pepper distributions of Flash Player 11.2 on Linux for five years from its release.

  • I tried chromium, still no luck with pogo.com any tips on how to make it work with chromium? – ScooterKat1231 Aug 18 '13 at 3:29
0

Google Chrome link

Download the package and then double click and enter password to install, it will take 3 minutes or so depending upon PC specs, other workaround may be chromium with pepper as stated above.

  • how is this an answer to the question? – Alvar Aug 18 '13 at 5:58
  • There is no flash player for linux beyond 11.2 which some websites treat as outdated, so to get latest flash you need to use either chrome or chromium with pepper-plugin. Before you question go through answers first. – Pulkit609 Aug 18 '13 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.