1

I tried to hibernate using pm-hibernate but when I start Ubuntu again I can't get to login screen.but when i tried to login lightdm keeps restarting and keeping me from login .

please help me? I'm new to ubuntu.

sudo startx

Fetal server error:
Server is already active for display 0
if this server is no longer running, remove /tmp/.X0-lock and start again
ddSignGiveUp: Closing log
Invalid MIT-MAGIC-COOKIE-1 KeyInvalid MIT-MAGIC-COOKIE-1 Keyxinit: giving up
xinit: unable to connect to X server: Resource temporarily unavaliable
xinit: server error 
1

What laptop do you have? Also, next time this happens try ctrl + alt + F2 and login. Then try

sudo service lightdm restart

You may need this in your grub config.

So in the terminal (ctrl + T) enter

sudo gedit /etc/default/grub

then find this line

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash″

and change that to

GRUB_CMDLINE_LINUX_DEFAULT=”quiet nox2apic splash″

then save the file and close. Then in the terminal again type.

sudo update-grub

and reboot.

  • I have Hp pavilion Dv6- 6b80ee. dual boot(ubuntu + windows) the problem is i can't x session (no GUI).lightdm kepps restarting.all i have right now is console (ctrl + alt + F2) – Mohamed Elsayed Aug 17 '13 at 14:47
  • it's not working.any suggestion? – Mohamed Elsayed Aug 17 '13 at 15:43
  • Can you provide an log? Have you tried "startx" from the command line? – thedemon Aug 18 '13 at 0:53
  • I did >>sudo apt-get install --reinstall xorg then reboot >>startx -- :1 and now it's working. thanks for your help :) – Mohamed Elsayed Aug 18 '13 at 9:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.