I have accidentally deleted some photos from my camera and than found out, that those photos were really precious to my girlfriend. I tried googling and both windows and linux tools to recover those files but no result.

The problem is, that when I plug in my camera I is mounted to /run/user/jendas/gvfs and mount says:

gvfsd-fuse on /run/user/jendas/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=jendas)

So I can not access my files with the tools I tried cause they always need something like /sda...

Please is there any way around? I don't wanna die :-(

Edit: Just to be clear, I do not really think, that path to my camera will be /dev/sda... I checked every location marked as fuseblk in corresponding mount directory and the camera is not there.

Here is what gives mount:

/dev/sda5 on / type ext4 (rw,noatime,nodiratime,discard,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
gvfsd-fuse on /run/user/jendas/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=jendas)
/dev/sdb1 on /media/jendas/Rezervováno systémem type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb2 on /media/jendas/EE2AC63D2AC60317 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb6 on /media/jendas/099218f3-ad22-4022-900f-c39b98049fdf type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdb4 on /media/jendas/Data type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /media/jendas/B4AED817AED7D04A type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

My camera is here listed as line, that I have already typed above.

Final edit: Finally I have recovered the pictures! So I won't be destroyed by mighty and terrifying feminine look. I the end I solve the problem by removing the memory card from camera and plugging it into another notebook with working memory card reader. Than I followed the standard procedure. I wonder, that my problems were probably caused by the camera it self and its firmware. I think that it handles the usb connection in some non-standard and creepy way so the kernel can't it properly identify as external removable drive.

So thank you all anyway and have a good day.

PS: I will accept the original answer posted lower because it helped me solve at least part of the problem :-)

  • you should get another line, something like that: /dev/sdb1 on /media/mike/244E31704E313C3C type fuseblk
    – Symin
    Aug 17, 2013 at 14:22
  • /dev/sdx would be a phisical device name, regardless of where its partitions are mounted. Sounds like you just need a decent Testdisk tutorial, so how about this one? Aug 17, 2013 at 14:22
  • Symin - nope, there are just my regular drivers of type fuseblk... @mikewhatever - I have tried dd if=/dev/sdx of=my_card.img bs=512 but result: dd: opening ‘/dev/sdx’: No such file or directory
    – Jendas
    Aug 17, 2013 at 14:33
  • if the camera is mounted as a gvfs partition it should be part of the /dev where it is mounted on. photorec should be able to catch it, give it a try following the directions below and selecting the /dev where the directory is mounted. Can you remove the memory from the camera and place it into a card reader or soemthing?
    – Cubiq
    Aug 17, 2013 at 15:11
  • Well I tried photorec but it did not found it :-/ And yes, removing the card a putting it into built-in card reader helped, but I had to place it into another notebook, because my has probably some driver issue. But thanks for your help :-)
    – Jendas
    Aug 17, 2013 at 15:19

1 Answer 1


First of all it is crucial that you do not write anything on the memory card until you recovered the deleted images.

Your best bet is PhotoRec. It is part of the testdisk package. Install it with

sudo apt-get install testdisk

Then run photorec as super user

sudo photorec

You'll be presented with the list of connected devices, including your hard drives. Select the memory card (it will probably be something like /dev/sdb or /dev/sdc but check it carefully). Follow the on screen instructions.

Another alternative is recoverjpeg that is specifically tailored for JPEG recovery.

Install it with:

sudo apt-get install recoverjpeg

Open "Disks" (you find it in your applications). You'll find the list of connected devices. Select the memory card. On the right hand you'll find the details of the device included where it is mapped (eg: /deb/sdb1)

Then you can try with recoverjpeg like so:

sudo recoverjpeg /dev/sdb1

IMPORTANT: replace sdb1 with your actual device!

You'll find the recovered pictures in your home directory.

Also have a look at this https://help.ubuntu.com/community/DataRecovery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.