1

After lot of searching I found out that my Linux Kernel is 3.5.0-37-generic and I am unable to install my Wireless Lan Card Driver which is Realtek RTL8723AE. For some reason when I try to command make after downloading all those file by wget it shows 2 errors. I just upgraded my linux headers files last night. But it still did not worked for me right from the beginning even before the upgrade by the Update Manager. Can anyone help on this please??

It's really problematic as I need to login from other's computers to make this posts. If It still does not work, I guess I have to quit using Linux as I a PC is worthless without Internet.

Thanks in advance.

6
  • Please edit your question to include the wording of the errors. Did you use the preferred later version of the driver? dl.dropboxusercontent.com/u/58267392/…
    – chili555
    Aug 17, 2013 at 0:37
  • @chili555 please, don't use personal file repository accounts for sources and binary files. If needed please link the source.
    – Braiam
    Aug 17, 2013 at 0:49
  • @user184803 could you edit your question and add the exact wget errors?
    – Braiam
    Aug 17, 2013 at 0:50
  • @Braiam I am unable to find that version on Realtek's site. If I had a source other than my Dropbox, I certainly would have used it. Several other solved cases suggest that, for 12.04, this version works correctly.
    – chili555
    Aug 17, 2013 at 1:25
  • 1
    I have already found the answer myself!! I just commented out the line for which the make command was showing error and it worked in current linux kernel. I found it interesting though I know this is not recommended may be. I also tried to answer it myself when it showed me that I can not answer my own question before 7 hours!! So, I guess I will have wait another 7 hours for that. Sorry to keep you waiting but anyways, thank you for your concern.
    – imcody
    Aug 17, 2013 at 1:36

2 Answers 2

1

I was just tweaking myself with my own risk, and came up with the solution. So I thought it would be wise for me to answer the question here. I am not a regular answer provider, but still I will try to be professional.

I must tell you that my system is a 32 Bit Ubuntu 12.04(Precise) LTS, Here is how you install the driver for Realtek RTL8723AE-BT Wireless Card. Open your terminal and type the following commands one by one.

sudo apt-get update
sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
wget -O- http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012.tar.gz | tar -xz
cd rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/

Give a pause here. and open your file explorer, and locate the file ~/rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012/base.c. Open the file with text editor, locate line number 320, turn the line to:

/* IEEE80211_HW_BEACON_FILTER | */

from

IEEE80211_HW_BEACON_FILTER |

in other words just comment it out. then go to the terminal again and continue.

make
make install
sudo modprobe rtl8723e

That is it, your Wireless Modem will work in your Linux Kernel Version 3.5.0-37-generic

4
0

Not sure if this is an answer but here goes.

I have Ubuntu 13.10 and kernel version 3.11.0-15-generic.

I have had this problem for a while with the wireless and searched but with no change. Wi-Fi would drop out randomly and was waaay weaker than on windows.

I reinstalled the drivers IN WINDOWS yesterday and for some reason, the Wi-Fi on Ubuntu is better. Not sure if that helps. But testing now and it seems fine. Will give it a go for a few more hours and see. :-)

5
  • 1
    There are two possibilities here: placebo or luck
    – Lucio
    Jan 9, 2014 at 21:30
  • There is absolutely no connection (apart from the person using them :-)) between the two systems - so what you are reporting is either coincidence or illusion.
    – guntbert
    Jan 9, 2014 at 21:32
  • It is a "Realtek RTL8723AE" card?
    – Braiam
    Jan 9, 2014 at 21:34
  • Yes, RTL8723ae on a Toshiba C850-F21H. So, after trying a few times there are times it fell out but now for a while (the past two days) its been stable. Really great range. But it seems to totally be random. During some boots it's great throughout for hours on end, and on some its terrible. What could be the difference between all these?
    – possumkeys
    Jan 11, 2014 at 7:28
  • And the thing for being totally unrelated, I don't quite agree, not because I have some strong understanding, its just that in the few 4 years I have dual booted on different laptops, there are times a change in Windows would render a device useless in Ubuntu until I went back to windows and changed it, and that has especially been the case with Wireless device and their drivers. Not sure why but that's the cause and effect I see. :-)
    – possumkeys
    Jan 11, 2014 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.