This question already has an answer here:

i was trying to uninstall wine, but the command i got from this site destroyed my ubuntu machine. the command was "sudo apt-get remove wine*" or --purge in place of remove would do same thing. it uninstalled everything. luckly i had everything on an external hdd.

so i reinstalled 12.04 64bit. started up virtual box, made a virtual machine for 12.04 32bit. (was going to test wine apps in it). the installation process was ok. but after reboot of the virtual machine, i get low graphics window at bootup. then i deleted and tried again. same thing.

i gave the virtual machine: 2 CPU cores 2GB ram 128MB video ram 3d & 2d acceleration. 16GB HDD.

my ubuntu 64bit machine has: AMD 4 core 16GB ram nvidia gtx 650 1TB+

It was working before the melt down. soo im not getting it... enter image description here

marked as duplicate by rɑːdʒɑ, Eric Carvalho, Isaiah, Seth, Alvar Aug 22 '13 at 16:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is that error message from the virtual machine or from virtual box itself? – Colyn1337 Aug 16 '13 at 22:22
  • the wm. its ubuntu giving the message – Alex Aug 16 '13 at 22:25
  • Did you get the right driver for your video card after reinstalling Ubuntu on your physical machine? – Colyn1337 Aug 16 '13 at 22:47
  • thanks for reminding me, but the 310 driver is the current one installed. ill try the older non-experimental one. ill update in a sec – Alex Aug 16 '13 at 22:57

First go into the VM's settings and enable 3D acceleration from Display. Then boot the machine and install the virtualbox-guest-utils package. After rebooting, the graphics problem should be resolved.

  • 3d acceleration is enabled in the display settings for the vm. and the farthest point i get is a CLI login. basicly no gui. – Alex Aug 16 '13 at 22:13
  • OK, then try logging in with your username and password, if you get a log in prompt, or you can get to one with <ctrl> - <alt> - <F1> (as long as <ctrl> is not the host key). Then you can install the package with sudo apt-get install virtualbox-guest-utils. – Richard Aug 16 '13 at 22:18
  • i made the edit and thats what i had to do. just running the install without iso didnt work – Alex Aug 17 '13 at 2:37
  • 1
    @Alex please, just write an answer using the box below, since what you propose is another solution, so you can get reputation for such. – Braiam Aug 17 '13 at 3:08

What worked for me was to go to the device menu then select Install Guest Additions. What it does is downloading an ISO and auto mounting it in the current VM.

Then all I had to do what was running:

sudo apt-get install virtualbox-guest-utils

Before installing the ISO this command didnt work. So install the ISO first.

Not the answer you're looking for? Browse other questions tagged or ask your own question.