3

The GUI printer install does not have the driver available. I downloaded the LINUX drivers for the printer from the Epson Website, and used the PPD to install. Returns a CUPS error. Installed the printer via localhost:631. It installed, but said it was missing a filter. Any ideas on how to get all the files where they need to be? Thanks!

6

I had the same problem with my Epson WF-3520 and the driver from the Epson-Website. This solved my problem:

Try, to make sure the damaged driver will be removed:

sudo apt-get -f install

And then install the driver from the package manager

sudo apt-get install printer-driver-escpr

I installed the package "printer-driver-escpr" version 1.3.0-1 with the package manager and the driver works for me with the Epson WF-3520.

Now, try to add a new printer.

Application -> System Tools -> System Settings -> Printers

Network priner with connection type:

LPD/LPR queue 'PASSTHRU'
| improve this answer | |
  • 1
    Just reporting that the above instructions worked for me on Ubuntu 16.04 with Epson WF-3620 All-in-One. Thank you @slatchham! – Беров Jun 5 '16 at 10:28
  • Thanks, this method worked for me too, got my print working over Wi-fi from Ubuntu 14.04! Just wanted to add that I input the IP address of my printer into the 'find network printer' option, and that seemed to automatically fill out the "LPD/LPR queue 'PASSTHRU'" values (in case anyone is unsure). – Big Rich Jul 17 '16 at 0:16
  • Reporting that the above instructions worked for me on Ubuntu 16.10 with Epson WF-3620. Thanks for the LPD/LPR queue 'PASSTHRU' hint. – Michael S. Jan 27 '17 at 9:38
1

I had a similar problem trying to install Epson WF-3520 on my Ubuntu 14.04 system. I think these general steps can be followed for any distribution of Linux. Many drivers are automatically recognized by Ubuntu when you configure your printer with your computer system (see step 5 below), but if your printer that is not automatically recognized by Ubuntu, then these steps should help. I followed the instructions found on this page: https://wiki.linuxfoundation.org/en/OpenPrinting/Database/DriverPackages and this is what I did:

  1. Open Synaptic Package Manager and search for lsb. Mark the box next to the lsb package for installation and click the Apply button to install it. A bunch of other packages will also be installed with the lsb package and that is okay.
  2. Go to Epson's Download driver's and Software site: http://download.ebz.epson.net/dsc/search/01/search/. Search for your printer (wf-3520) and your operating system (Linux).
  3. Click the Download button next to the ESC/P Driver (full feature) Printer Driver. Click Accept and then download the driver for your computer system. For example, my computer has an AMD 64-bit processor with Ubuntu 64-bit, so I would download the driver that ends with amd64.deb. (In case you didn't know, Ubuntu uses .deb packages.) This driver should open in the Ubuntu Software Center by default, so you may have to close out Synaptic before you try to install the driver, but maybe not. Click the Install button to install the driver.
  4. If you do not already have the dpkg package installed, then open Synaptic again, search for dpkg and install it the same way you did with the lsb package above. By the way, dpkg is the Debian package management system, so you should already have it installed on your system. But in case it is not, you can install it as I have explained.
  5. Now you need to configure your printer so your computer will recognize it. Turn on your printer and connect the USB plug from your printer to your computer. Click your Ubuntu button (the same one you click to shut down your computer) --> System Settings --> Printers --> Add. You should see your printer as one of the options to add. Select your printer and follow the prompts to add your printer. The default settings that are pre-filled should all work, so you can just use those settings.
  6. That's it! You should be set now. You should run a test page to make sure that everything worked. In the System Settings dialog box, click Printers --> double-click your printer in the Printers dialog box and click Print Test Page. If everything was set up correctly, then your printer should print a test page.

I hope that helps.

Happy printing!

| improve this answer | |
  • I set mine up a long time ago. I had no trouble with it. But only the printer works. I have no scanner support on Linux. Is there any scanner support available anywhere? – Joe C Feb 6 '15 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.