I was trying to install adobe reader and it didn't finish installing. Then I decided that I dont need adobe reader and how do I have ubuntu think everything is fine and there are no unmet dependencies or have ubuntu get those dependencies? I need to resolve this error because my system is running out of memory because of apps and I cant install or uninstall packages. I have tried sudo apt-get install -f and I get this:

[sudo] password for harley: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
Suggested packages:
  libldap2 libgnome-speech7
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 213 not upgraded.
1 not fully installed or removed.
Need to get 60.1 MB of archives.
After this operation, 142 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://archive.canonical.com/ubuntu/ raring/partner acroread-bin i386 9.5.5-1raring1 [60.1 MB]
Fetched 60.1 MB in 35s (1,676 kB/s)                 
(Reading database ... 158479 files and directories currently installed.)
Unpacking acroread-bin (from .../acroread-bin_9.5.5-1raring1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/acroread-bin_9.5.5-1raring1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/firefox/plugins', which is also in package adobe-flashplugin
No apport report written because MaxReports is reached already
         dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried sudo apt-get remove acroread-bin and I get this

[sudo] password for harley: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'acroread-bin' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
acroread : Depends: acroread-bin but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried all of the soloutions from How do I resolve unmet dependencies? that I could (all of the ones that use terminal only)

  • Can you try sudo apt-get remove acroread-bin and let us know if that fixes the problem? – roadmr Aug 16 '13 at 16:33
  • Welcome to Ask Ubuntu! If you solved the problem, please post an answer explaining how it was solved (answering your own questions is not merely permitted, but encouraged when there is no other answer that does the job). – guntbert Aug 16 '13 at 23:05

There is essentially no way to make Ubuntu ignore all unmet dependency errors. And if you did achieve that, then you would create a system in an inconsistent state where different parts couldn't work together as designed. Which would be bad.

But if you decide to back out of installing something, that you can do. Most of the time, you can successfully uninstall a stuck "half-installed" package. For some packages, this should be avoided (or simulated first with apt-get -s to make sure removing them won't remove lots of other needed packages). But for something like Adobe Reader, it should be safe to go ahead and attempt uninstallation, like roadmr suggests:

sudo apt-get remove acroread-bin

This will most likely also uninstall other Adobe Reader related packages (any that depend on acroread-bin). But you want that, because those packages cannot run without it.

If you get errors removing acroread-bin, of course please let us know.

Alternatively (whether or not there are errors removing it), you might just want to try some of the solutions to How do I resolve unmet dependencies?

  • Presumably with sudo apt-get remove acroread acroread-bin – joeytwiddle Sep 14 '13 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.