This question already has an answer here:

I am running Lubuntu on my laptop and would like to write French accents with a US keyboard. I find the compose key solution ([Alt]+[accent] at the same time, followed by a [letter]) not that handy...

On Windows, there is a better solution: switch the keyboard layout to US-international and then type [`] followed by [a] to display [à]. Still on Windows, the software EasyType makes it even easier: press once [e] to get [e], twice [e] to get [é], three times [e] to get [è]...

Is there a way to achieve that on lubuntu? With a script or something?

PS: My keyboard is Vietnamese, but exactly corresponds to the US keyboard.

marked as duplicate by Kevin Bowen, Warren Hill, Jorge Castro, belacqua, Alaa Ali Sep 20 '13 at 20:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't feel this is a duplicate, but a specific question. To Windows users familiar with International Keyboard, you want it to work as the OP describes: type [`] followed by [a] to display [à] – Fuhrmanator Sep 22 '14 at 20:13
  • In Ubuntu 14.04 it's System Settings > Keyboard > Text Entry > + (Add Input source) > English (US, international with dead keys). It's not perfect, however. Trying to do a C - cedilla is not the same, but yields ć. The other accents é ê è ë in French seem to work OK. – Fuhrmanator Sep 22 '14 at 20:20
  • For the cedilla problem, see this answer askubuntu.com/a/428619/148933 – Fuhrmanator Sep 22 '14 at 20:25

Use the keyboard layout called English (international with Alt Gr dead keys). (Do this by going to System Settings > Keyboard > Layout settings, and then add the layout you want with the + button on the bottom.)

This way, the keys to input the characters ', ", `, ~, and ^ become "dead keys" while you hold pressed Alt Gr. After releasing the key combination with Alt Gr, no characters will be print (hence "dead"), but inserting a letter afterwards will yield a variation of the base character of the letter, in accordance with the dead key you pressed before; for example, é, ë, è, , and ê for e (respectively). (If you have no explicit Alt Gr key, just use the rightmost Alt key.)

So in summary, to insert a symbol

  1. press and hold Alt Gr,
  2. press the modifier key / key combination; e.g., `,
  3. release all keys pressed so far, and
  4. press the base character key; e.g., E for è.

Note: You can also enter an acute accented vowel by just pressing Alt Gr + (vowel).

(Source: this post on french Ubuntu forums.)

  • Actually the layout English (international AltGr dead keys) doesn't work for me. If I press [AltGr] and [`] and [e], I get [é] instead of [è]. – rom Aug 16 '13 at 6:55
  • Could it be because my keyboard is Vietnamese? (but corresponds to the US one) – rom Aug 16 '13 at 7:04
  • I updated the description because it was a bit lousy. Now, I suspect you are pressing all keys at once, are you not? Press simultaneously only Alt Gr and the "dead key", release, and then insert a letter. (I have now described this in my answer.) Are you still unsuccessful? – Severo Raz Aug 16 '13 at 7:56
  • I have tried again following your instructions. Still not working. If I press [Alt]+[`] at the same time, then release the keys (no output), then press [e], I just got [e]. I have tried with the two Alt and other accents. – rom Aug 16 '13 at 9:13
  • 5
    I stumbled on this question looking for something else. The AltGr with dead keys is a pain to use (at least for fast typers). I think that a better option is the 'US internation with dead keys' (no AltGr in the description). There you just type the accent and the letter. For instance type ' (no alt, no ctrl, no nothing) followed by e and you have é. – rpsml May 2 '14 at 15:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.