24

I used to save images as usual image file formats (jpg, png) by pressing Ctrl+S or Ctrl+Shift+S (Save or Save As dialog). Now in version 2.8 GIMP doesn't allow it anymore: you can Save only as .xcf but to save as .jpg or .png you must Export.

Is there a way to get this old file saving functionality back?

  • Here is my approach to this new "feature": askubuntu.com/questions/284493/avoid-save-for-web-in-gimp – Takkat Aug 15 '13 at 19:05
  • What do u do if Export and Flatten are ghosted? – user266935 Apr 9 '14 at 4:07
  • 13
    It's basically bad product design, and it commits a product design sin. What they were thinking was: "People aren't using Export like we want them to. Let's break the Save feature to prevent them using it the want they want, forcing them to use Export instead". What they should have done: "People aren't using Export like we want them to. Let's find out what they are doing instead and re-consider having this separate Export feature". – thomasrutter May 13 '14 at 2:35
13

I remember reading on heise (german) that someone wrote a plugin to revert back to the old functionality.

Runnning the following commands in a terminal will download the latest version of the plugin to Gimp 2.8's config directory and make it executable:

gimp_dir=".gimp-2.8"
wget https://github.com/akkana/gimp-plugins/raw/master/save-export-clean.py -O ~/${gimp_dir}/plug-ins/save-export-clean.py
chmod a+x ~/${gimp_dir}/plug-ins/save-export-clean.py

But I have to say that it's not a big deal learning the new shortcut Ctrl+E. Also having a clean distinction between destructive export and save is actually a good thing.

  • Great! Now if only this plugin could 'steal' Ctrl+S and Ctrl+Shift+S shortcuts... – Nickolai Leschov Aug 16 '13 at 15:05
  • 3
    Of course you can bind it to Ctrl+S. Simply go to Edit | Keyboard Shortcuts, search for Save/Export clean and assign it to Ctrl+S. – gilbertohasnofb Dec 7 '14 at 17:51
  • Vote up this answer for the ctrl+E command! – Enrico Maria De Angelis Jan 7 '17 at 14:56
  • 2
    An important comment from the top of the script: Warning: this does not show a lot of extra dialogs, etc. or warn you if you're about to overwrite something! Use with caution. – Pikamander2 Apr 28 '18 at 7:45
  • You can use Ctrl+E as export instead of Ctrl+S (or even rebind "export as" to Ctrl+S), but it's not perfect, GIMP doesn't consider an "export" a "save", so when you close the image you'll get a "do you want to save" prompt even though you already technically "saved". – jrh Nov 24 at 16:53
13

Starting from GIMP 2.8 we need to use the "File → Export" or "File → Export to..." menu entries, or alternatively the Ctrl+E or Ctrl+Shift+E keyboard shortcuts respectively, which will result in the Export dialog to allow you to save the work in your favorite image format.

The former Ctrl+S and Ctrl+Shift+S is now used to work with the project only. To save the project or "Save as" the project.

Good luck!

enter image description here

For the comment of @Eric Leschinski I am dropping this edit:

That's about how you use your software. Many people uses mouse and it's ok if they love to do so. Personally I made my process as OpenFile/Tweak/Export/CloseFile[CloseGIMP] in a faster way by doing the CtrlO/Tweak/CtrlE/CtrlW[CtrlQ] and it takes 3~5 seconds (depending on your machine's speed. For the "Save as" Process it takes just one more step but it did the same before. So I suggest you to start by tweaking your key binding in order to make it faster. Good luck!

  • @EricLeschinski I added an edit for you. – Geppettvs D'Constanzo Mar 14 '15 at 19:44
  • 3
    Changing the process of: Openfile/tweak/ctrl-s/exit operation into "openfile/tweak/ctrl-e/ctrl-w/ctrl-q" seems like someone trying to completely ruin the one thing that image editors are supposed to be good at: editing images. Why not add 5 more keyboard combinations to the mix so it takes 20 minutes to edit an image? Whoever responsible for this needs to be punched. – Eric Leschinski Apr 4 '15 at 21:46
  • 1
    Changing the process of whatever the Software did before seems like someone is inviting us to evolve with the upgrades. It's on ourselves to choose whether to accept the challenge or not. Good luck on whatever you choose, my friend! – Geppettvs D'Constanzo Apr 7 '15 at 4:46
  • Any explanation to why this clear regression in behavior was accepted? Clearly not an improvement in any way! – NiKiZe Jun 30 '16 at 15:04
  • 1
    While the idea of inventing such a workflow is certainly to be welcomed, the idea to force it upon the users is definitely not. It should be made optional, so those who want it can enable it and those who don't can stick with the "easier" way – which after all is how the majority is used to work. </rant> But that's nothing we can solve here at AU, that must be addressed at the Gimp team. Luckily, there are at least some work-arounds, as described in the other answers. The one by Smile4ever works great for me. – Izzy Jan 8 '17 at 14:03
1

Starting from GIMP 2.8, the behaviour changed:

  • XCF is now the default format for saving images. This is because of the non-destructive nature of this file format: it retains the layers in the image.
  • PNG/JPEG are import and export formats. Use File -> Open to import these and File -> Export (or Overwrite) to save PNG/JPEG images.

This change was done to prevent people from accidentally losing their layers. However, this change has received immense criticism from many users.

To revert to the old behaviour as was the case in GIMP 2.6, follow these steps:

  • Download https://raw.githubusercontent.com/akkana/gimp-plugins/master/saver.py
  • Save to ~/.gimp-2.8/plug-ins/ (so the location becomes something like /home/myuser/.gimp-2.8/plug-ins/saver.py)
  • Make saver.py executable: chmod +x saver.py
  • Restart GIMP
  • Go to Edit -> Shortcuts and search for "Saver"
  • Assign the shortcut CTRL+S to "Saver". Confirm you want to reassign the shortcut.
  • Assign the shortcut CTRL+Shift+S to "Saver as". Confirm you want to reassign the shortcut.

Now you can simply use CTRL+S (save) and CTRL+Shift+S (save as) to save your files. Also, on exit GIMP won't ask to save your files to XCF anymore (if they have already been saved with saver).

Now train yourself: in the File menu, use "Saver" and "Saver as". This two commands replace these 4 items: Save / Save As / Export / Export as. So click "Saver" or "Saver as" from now on :)

0

Press ctrl+E and you will be able to save it in other formats like jpg png or go to file and click on Export.... and you will be able to save it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.