After installing Ubuntu server 12, I get the message "out of range" from my monitor (Asus vh236h). The PC is a Compaq Proliant ML310 G1. I have verified that it is up and running otherwise, by using ssh to access the computer remotely.

This message happens at the point exactly prior to when the grub should appear. I cannot see anything except the "out of range" from that point onward. Using the install disc's rescue mode to access terminal commands, I've tried changing the /etc/default/grub file to several different resolutions, doing a sudo update-grub after, none of which worked. I thought maybe it's the frequency that is the problem (which I don't know how to change) but I have also tried uncommenting GRUB_TERMINAL=console, but that didn't help either.

Edit: I saw in another post's comments that grub doesn't show unless you hold Shift, so I tried that. I saw "grub loading.." then my monitor started displaying "out of range" again, like before.

  • Isn't it a message displayed by your monitor, independently from the machine itself ? – John WH Smith Aug 15 '13 at 9:30

Yes, it was obviously a message from the monitor itself, as I was seeing the BIOS messages. I figured out from a combination of other questions on various forums how to make it work. I edited the /etc/default/grub file, changed




uncommented the resolution line and set it to something I knew my video card should support, 1024x768.

Not sure if it was one or both of these things that actually fixed my issue. Turns out I had actually NOT saved the changes the first time by sudo update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.