How do I disable mouse acceleration and still get my mouse to go fast? The settings in the menu are too slow and don't disable the acceleration fully. I've tried doing xinput set-prop '11' 'Device Accel Profile' -1 and xinput set-prop '11' 'Device Accel Constant Deceleration' 1/5.

Although it gets rid of the acceleration the mouse moves very slow now. Even xset m 2 0 doesn't change anything after I enter the xinput codes.

How can I increase mouse speed while getting rid of mouse acceleration?

I'm using Ubuntu 12.04 LTS.

Device Accel Constant Deceleration can't be set lower than 1.0, so it sets it to 1.0 when you try setting it to 1/5. You can check this using xinput list-props 11. (I'm actually guessing it doesn't read the "/5"-part, because I get an error message when trying to set it to for example 0.5, but setting it to 1/5 actually sets it to 1.0).

If you don't want acceleration (which I completely agree with), the only thing you can do to improve the pointer speed is to set Device Accel Constant Deceleration to 1.0. If the pointer doesn't move fast enough for you then, I think the only fix is to get a mouse with higher DPI (or set your mouse to a higher DPI if you have a mouse with adjustable DPI).

The way to set it is in terminal not xset m.

First, use xinput --list --short and write down your mouse ID. Mine is (8). Save it.

Next, in the terminal, type:

xinput --list-props yourMouseId

Press enter and find the Device Accel Constant Deceleration #. Mine is (270). Write it down, behind your mouses ID.

Now, in the terminal, type:

xinput --set-prop 8 270 7

If this is too slow, retype the command but lower the last #. Try 6 or 5 or 4 and down till you got the speed you like.

One last thing: If your mouse is too slow, try going into the settings of mouse and touchpad and use the speed slider there to your liking.

On my ubuntu 14.04 system, I seem to be able to accomplish scaling of the mouse sensitivity by adjusting 'Device Accel Constant Deceleration'. It doesn't accept a numerator/denominator (if you try to give it one, it just takes the numerator), but it does accept numbers less than 1 (the lower the number, the faster your pointer will go w.r.t. how fast you move the mouse). So, try using .2 instead of 1/5. xinput --list-props 11 should then show it as .200000.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.