I have a problem similar to this : While using internet on ubuntu, all other computers get bad internet connection

So the problem is, whenever I log onto Ubuntu Internet, all other computers Internet speeds goes down drastically. We have 20 Mbps download and 2 upload. However, when I log onto Ubuntu I can still get this on this computer but all other computers go to about .2 Mbps upload.

When I log into Windows on the same machine the Internet works fine on all other computers. I tried the fix mentioned in that post i.e. I tried "sudo iw reg set US" in vain.

OS: 13.04 Network Card:

       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       logical name: eth1
       version: 01
       serial: c0:cb:38:0f:b4:50
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= (r326264) ip= latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:fbd00000-fbd03fff


eth0      Link encap:Ethernet  HWaddr f0:4d:a2:94:2a:8a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr c0:cb:38:0f:b4:50  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::c2cb:38ff:fe0f:b450/64 Scope:Link
          RX packets:6229 errors:1 dropped:0 overruns:0 frame:15408
          TX packets:5608 errors:11 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5849916 (5.8 MB)  TX bytes:1117895 (1.1 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:842 errors:0 dropped:0 overruns:0 frame:0
          TX packets:842 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:118319 (118.3 KB)  TX bytes:118319 (118.3 KB)

dmesg output is pasted here: http://paste.ubuntu.com/5987128/ . One thing I have noticed is after I do the iw reg set US it appends the following to dmesg output:

[  805.955556] cfg80211: Calling CRDA for country: US
[  805.963964] cfg80211: Regulatory domain changed to country: US
[  805.963973] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  805.963980] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[  805.963987] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[  805.963993] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  805.963999] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  805.964005] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  805.964010] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)

which is automatically removed after every reboot. Any advice or debugging assistance will be greatly appreciated! Thanks!!

  • If you disable the wireless card, do the problem go away? Try unloading the wl module and loading brcmsmac instead: sudo modprobe -r wl && sudo modprobe brcmsmac
    – Braiam
    Aug 15, 2013 at 1:46
  • This is also a posible bug with the restricted drivers according to this comment in the Launchpad bug report: Interference with other devices on local WLANs
    – Braiam
    Aug 15, 2013 at 1:54
  • @Braiam Thanks for pointing me to the bug report. I observed the interference problem but I ignored it thinking its too weird. The loading/unloading of the wl module helped but the internet speed on other devices is still half of what my ubuntu laptop is getting! Thanks a lot for the help! Aug 15, 2013 at 3:10

1 Answer 1


So the solution to the problem if it aint solved by:

sudo apt-get install iw
sudo iw reg set US

is to unload the 'wl' kernel module and load the brcmsmac like Braiam said:

sudo modprobe -r wl && sudo modprobe brcmsmac

Thanks Braiam

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.