1

In CCSM, I have "click to focus", "raise on focus", and "auto-raise" checked. I have "auto raise delay" 100 and "focus prevention level "Very High"

When I hover my mouse over a window that does not have the focus, but does have a scroll bar, and I move the scroll wheel on my mouse, the window scroll bar moves up and down, but the focus does not move from the focused window to the window I'm scrolling.

This is bad, because my brain then thinks that window has focus when it does not. Invariably I will then begin typing, thinking my new window has focus. This can have disastrous results; I've lost folders of email this way.

How do I fix this crazy behavior? I want click to focus for everything, including scrolling.

  • 1
    Well, I think most people (who use Unity or GNOME Shell) are quite used to this behavior, I actually like it very much (and hate when I cannot do it under Windows). I remember that on Xfce by default the third button behaves as you want it. – edwin Aug 14 '13 at 22:50
  • I've removed overlay scrollbars, which I have always hated, but that didn't fix the problem. Looking in to xfce. – Adam Aug 14 '13 at 23:06
1
+50

I think that the best option for your request/issue is to go in CompizConfig Settings Manager, select General Options, Focus & Raise Behaviour tab, and uncheck Click To Focus and Auto-Raise options:

Focus & Raise Behaviour

If you want that the window in which you go with the mouse to scroll to come on top of the other windows, you can keep Auto-Raise checked, but in this case I suggest you to increase the value for Auto-Raise Deleay somewhere around 1000.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.