I faced this problem when I bought a new HP Laptop, hoping to install Ubuntu, but when I booted from a Live DVD the brightness was set at max and couldn't be changed with the function keys or from the brightness settings bar, and it was the same after installation.

  • HP Probook 4440s
  • Intel core i5 3210m
  • Intel HD 4000 graphics
  • 6gb ram
  • Motherboard-HP

2 Answers 2


After a lot of searching on the net, I tried the acpi_backlight=vendor kernel option, and it worked! Not only for Ubuntu, but for other Linux OSes as well, so I am posting a guide.


Restart your system, and when you get to the GRUB menu, select your distribution (Ubuntu 13.04), don't press enter, but instead press e (to edit).

This will bring up your menu entry for editing.

Append to the line with starts with linux (and looks like linux /boot/linux3.9. ............

At the end of this line, leave a space and add acpi_backlight=vendor

so that it looks like

linux   /boot/vmlinuz-310-x86_64 root=UUID=3161dd63-38c0-44bc-bc1e-34b692209b0b ro acpi_backlight=vendor

After this press F10 to boot.

Now try changing the brightness. It works for me.

Making this permanent

To make the change permanent we need to edit the GRUB configuration file

In a terminal type

sudo -H gedit /etc/default/grub

This will open the Grub configuration file.

In this file we have to edit the line




After that save the file and run (type in the terminal)

sudo update-grub

to update the GRUB configuration file.

That's It! Now the brightness settings can be changed any time and will be persistent across reboots (at least for me!)

If anyone has queries please post them here.


Since Linux 3.16, the kernel by default uses the native backlight method, so the above steps could be redundant.

Source: https://wiki.archlinux.org/index.php/Backlight#Kernel_command-line_options


I have a Samsung Series 9 NP900X3C, which has a Intel HD Graphics 4000 chip. When I use the the Fn keys for changing the brightness, it shows me a nice OSD and sets the value in


However, this doesn't do anything to the actual screen. Instead, I have to

echo $number >> /sys/class/backlight/intel_backlight/brightness

This is with the acpi_backlight=vendor option. If I remove it, the OSD turns up, changes the right brightness file, and the keys work! Only the brightness level does not get saved between reboots.

  • Perhaps you could manually symlink /sys/class/backlight/samsung/brightness to /sys/class/backlight/intel_backlight/brightness (dont know if it would be persistant across reboots though)
    – abchk1234
    Dec 20, 2013 at 14:40
  • They don't contain the same scale of numbers. Anyway, removing the option makes everything makes it work, albeit the setting vanishes between suspends.
    – user207046
    Dec 21, 2013 at 23:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .