I have a laptop dual booted with Windows 8 and Ubuntu 13. When the computer boots, it goes straight to windows. The only way I can get to grub is to reboot windows into advanced boot mode with shutdown /r /o /t 0.
This first happened after the windows 8.1 preview install failed. I had to do a system refresh to get windows working again. It was the same, but after running boot-repair, it worked fine. I don't know what caused the issue this time. However, running boot-repair doesn't work. Also this time, it gives me this message:

The boot files of [The OS now in use - Ubuntu 13.04] are far from the start of the disk. 
Your BIOS may not detect them. 
You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). 
This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. 

I don't know how to make this partition or how it will affect my system. The windows partition is first. I don't know if this partition existed but windows deleted it, or if it never existed and something else has changed.

My partitions on my single hard drive are

  • /dev/sda1 FAT32 300 MiB SYSTEM
  • /dev/sda2 ntfs 600 MiB RECOVERY //The windows recovery partition, I think
  • /dev/sda3 unknown 128 MiB
  • /dev/sda4 ntfs 137.37 GiB OS //The windows partition
  • /dev/sda6 ext4 135.83 GiB //The linux partition
  • /dev/sda7 linux-swap 3.89 GiB
  • /dev/sda5 ntfs 10.4 GiB Restore

Thank you in advance. if you need more information, please ask.

  • Are you using Windows in UEFI mode? – abchk1234 Aug 14 '13 at 15:11
  • 2
    Yes. After rebooting again it worked. Don't know why, I got the same thing on boot-repair. I'm going to delete the question soon. – BillThePlatypus Aug 14 '13 at 16:33
  • did you check the boot order in bios? ubuntu must be first boot option or the GNU grub does not show and it directly goes to windows. – mkxone Sep 16 '15 at 17:20

I had the same issue. Fix:

  1. Boot Ubuntu from live DVD or USB
  2. choose "try Ubuntu"
  3. install Boot Repair
  4. Recommended repair
  5. follow instructions
  6. You should now get to choose between windows and ubuntu when you boot up your PC.

Worked for me.

| improve this answer | |
  • I already ran boot-repair from ubuntu because I was able to get into it. After running boot-repair for the umpteenth time, it rebooted and worked. It even gave me the same message about being too far from the start of the disk. What happened? I think I may have run sudo update-grub at some point. – BillThePlatypus Aug 17 '13 at 12:47

Are you going straight into windows 8? And you have to boot from a live disk?

If so, did you disable "fast boot"/"hybrid boot" in windows 8? Use the following steps to see if it is enabled:

Instruction to disable "fast boot" or "hybird Boot":
1. In windows 8 visit the control panel.
2. Search for "change what power buttons do".
3. Then click the link with the same name.
4. Click the link called ‘Change settings that are currently unavailable’.
5. Then simply scroll down and under the sub-heading ‘Shutdown settings’,
6. Remove the check mark of the option called ‘Turn on fast start-up (recommended)‘.
7. Then click on the ‘Save changes’ button below to close the window and apply the changes.
8. Go and "Shutdown" Windows 8. Do not restart. You must let it shutdown.

If you have done this I apologize for the tutorial above.

| improve this answer | |
  • I have it disabled already. It somehow fixed itself. I would delete the question if I could, but it needs a moderator. – BillThePlatypus Aug 17 '13 at 12:45
  • @BillThePlatypus The fixing itself happens every couple of updates in Windows 8 for me. – david_p Aug 17 '13 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.