18

I'm using GNOME Flashback (No effects) on Ubuntu 13.04 and I've got six workspaces however when entering System Settings -> Keyboard -> Shortcuts -> Navigation I only see options to address the initial four.

It used to be options up to 12 workspaces there and as I certainly don't need that much, I want to have at least enough for the amount currently active.

How can I restore or add more shotcuts specifically to navigate and move windows to workspace 5 and 6?

22

The only way I have found to modify the keyboard shortcuts for workspaces 5 and up in GNOME Flashback, is through a shell using the dconf command.

$ dconf read /org/gnome/desktop/wm/keybindings/switch-to-workspace-1
['<Primary>F1']

Here I read the shortcut setting for the first workspace, to get an idea about the syntax to use when setting values for the missing shortcuts. I'm using CTRL+ F1 myself.

To add shortcuts for the remaining workspaces, just modify the value returned above to match the workspace number, and use dconfto apply them:

$ dconf write /org/gnome/desktop/wm/keybindings/switch-to-workspace-5 "['<Primary>F5']"
$ dconf write /org/gnome/desktop/wm/keybindings/switch-to-workspace-6 "['<Primary>F6']"
  • works on 15.04 as well, thank you – jcupitt Aug 17 '15 at 7:45
  • Aha, there they are! Can somebody explain why the answer with -1 votes is above the correct answer with 6 votes? – Hubro Oct 5 '15 at 3:16
4

Maybe a slightly more comfortable way then using dconf on the command line is dconf-editor. Run dconf-editor and then navigate to

org -> gnome -> desktop ->wm ->keybindings

There you can find and edit the switch-to-workspace and move-to-workspace commands for workspaces 1 through 9.

0

I don't know how to add more shortcuts but you can use alt+ctrl+right/left arrow to move between the workspaces

(and you can use alt+ctrl+shift+right/left arrows to move windows to other workspaces)

I always use those

  • I use those but I also like to jump to a specific one, thanks anyway. – Samus_ Jan 3 '14 at 14:09
-2

hey I found something!

go to system settings (from the applications menu up to the left, utilities, system settings)

click "keyboard"

click the "shortcuts" tab

click "navigation" (should be the second item on the menu to the left)

"switch to workspace _" those should be the ones! ... and you have many other shortcut options to tweak!

  • like I said, it "used" to be there but it isn't on recent versions. – Samus_ Apr 3 '14 at 0:12
  • In the most recent version of Gnome, it only lists workspaces 1 through 4 – Hubro Oct 5 '15 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.