2

This question already has an answer here:

I'm using Ubuntu 13.04 3.8.0-27-generic and I cannot use my TL-725N nano wireless adapter.

lsusb :

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 005: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 003 Device 004: ID 05e3:0727 Genesys Logic, Inc. microSD Reader/Writer
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 07d1:3300 D-Link System DWA-130 802.11n Wireless N Adapter(rev.E) [Realtek RTL8191SU]
Bus 001 Device 004: ID 2232:1035  
Bus 002 Device 003: ID 8087:07da Intel Corp. 

I installed this : https://code.google.com/p/realtek-8188cus-wireless-drivers-3444749-ubuntu-1304/ But nothing appened, even after reboot. I still can not see the device in the network manager.

sudo modprobe r8712u did nothing and here is the result of iwconfig:

wlan1     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"gagman"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:13:A3:0A:B8:0D   
          Bit Rate:54 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=89/100  Signal level=71/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dmesg | grep r87

[   12.628932] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[   12.630039] r8712u: Staging version
[   12.630049] r8712u: register rtl8712_netdev_ops to netdev_ops
[   12.630050] r8712u: USB_SPEED_HIGH with 4 endpoints
[   12.630511] r8712u: Boot from EFUSE: Autoload OK
[   13.046262] r8712u: CustomerID = 0x0006
[   13.046264] r8712u: MAC Address from efuse = c8:be:19:de:b6:96
[   13.046264] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[   13.046320] usbcore: registered new interface driver r8712u
[   17.937068] r8712u: 1 RCR=0x153f00e
[   17.937822] r8712u: 2 RCR=0x553f00e
[   40.011329] r8712u: wpa_set_encryption, crypt.alg = WEP

Thanks

marked as duplicate by David Foerster, Pilot6, A.B., Eric Carvalho, waltinator Aug 20 '15 at 6:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It seems that you have two wireless devices, wlan0 and wlan1. I assume wlan0 is the USB. If you don't want to use the other wireless, I suggest you blacklist its driver. Everything looks perfect to me otherwise. – chili555 Aug 13 '13 at 22:16
  • I am using a laptop, I have a internal wireless device who is working very badly, I have a wireless usb adapter (wlan0), but this one is big, so I bought a small one. The Bus 003 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. And I can not use it. – Artyom2033 Aug 13 '13 at 22:27
  • Again, I suggest you blacklist the internal. Find out its driver with: sudo lshw -C network – chili555 Aug 13 '13 at 23:34
3

I downloaded and installed this driver (from the zip) : https://github.com/lwfinger/rtl8188eu And it worked.

  • Important to know: there are TWO versions of the "TL-WN725N", one needs the RTL8188CUS driver, the other needs this RTL8188EU. See wikidevi.com/wiki/TP-LINK_TL-WN725N_v1 and wikidevi.com/wiki/TP-LINK_TL-WN725N_v2 for differences. – Lekensteyn Aug 27 '13 at 10:51
  • my tp link is still not recognized. why? – Oki Erie Rinaldi May 2 '14 at 9:10
  • Thanks so much for this. I downloaded and installed it using the DKMS method, which proports to automatically recompile when you upgrade to a new kernel (boss). It works perfectly on Ubuntu 12.04 3.2.0-74-generic. – Jack Senechal Dec 25 '14 at 21:48
1

The correct driver for your device is not the one you installed, but rather r8712u:

modinfo r8712u | grep 3300
alias:          usb:v07D1p3300d*dc*dsc*dp*ic*isc*ip*in*

It is included by default in 13.04. Please try loading it:

sudo modprobe r8712u

Any errors or warnings? Is a wireless interface created?

iwconfig

If not, check for clues here:

dmesg | grep r87

If simply loading it gets your device working, add the module to be loaded automatically:

sudo -i
echo r8712u >> /etc/modules
exit
  • This is not for my TL-WN725N, but for my D-Link adapter. – Artyom2033 Aug 13 '13 at 20:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.