A few days ago I installed Ubuntu 13.04. After installation I ran few programs one by one to see that if everything worked fine.

At that time the Software Center ran and it listed some software in the window. But now two days after installation, when I open the Software Center it does not list any software at all. I closed it and ran it from terminal by typing sudo software-center as suggested in some forums, the terminal shows the following error:

root@engrali-OptiPlex-760:~# sudo software-center
2013-08-13 21:23:50,366 - softwarecenter.ui.gtk3.app - INFO - setting up proxy   'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 75, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
 File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

please, can someone help me to solve this problem?

  • Close-voters: there is probably a bug somewhere in here, but I believe most of what this question is asking is not a bug and would not be covered by workarounds in a bug report or even by a bug fix. (See my answer.) I recommend keeping this open. If after more information is provided it turns out that there's nothing significant here except a bug report, we can always close this at that time; I recommend against closing it now. Aug 14 '13 at 1:27

It is not generally necessary to run Software Center as root. (I understand you might have been running it as root to try to work around another problem; I've addressed this below.) If you run it as a normal user and try to install or remove software, it will ask you for your password to perform just that action as root. It does this automatically.

The actual condition you've experienced when running Software Center as root with sudo is probably a bug, but it's somewhat common for bugs to occur in software that is run as root, when the developers didn't intend for it to be run that way.

I recommend reporting a bug, but running Software Center not as root will probably solve your problem. (Just run: software-center)

As for the problem of the Software Center not listing any software: make sure Software Center is not running, then try removing your user-specific Software Center configuration files, its global configuration files, and reinstalling it. To do all that, open a Terminal window (Ctrl+Alt+T) and run:

sudo killall software-center
sudo killall -KILL software-center
cd ~/.config && sudo rm -r software-center
sudo apt-get update
sudo apt-get --purge --reinstall install software-center

(Normally it would not be necessary to run rm -r software-center with sudo, but since you've attempted to run software-center as root with straight sudo at least once, root might own files contained in that directory. In the future, to run a graphical program as root, you should generally use gksudo, sudo -H, or sudo -i and not plain sudo.)

After running those commands, try running software-center (not as root, not with sudo) and see if it works. If it does not, then please edit your question to include all the text from the terminal starting with the beginning of the line on which you entered the first command listed above, and continuing through the end of the output of software-center.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.