49

I download the tar.bz file from the home page of zotero, extract it and run the file 'run-zotero.sh', but it open zotero rather than install it. How to install it? Any help or suggestion will be appreciated!

3
  • which version of Ubuntu you are using ??
    – rɑːdʒɑ
    Aug 13, 2013 at 14:55
  • I use ubuntu 13.04 Aug 13, 2013 at 15:01
  • Just a quick note to let you know there is a github repo that should help all debian-based distro to install it with minimal hassle: github.com/retorquere/zotero-deb Best
    – mateMat
    Jan 20, 2020 at 15:31

8 Answers 8

48

I suggest you add a ppa so that the program gets updated regularly:

sudo apt-add-repository ppa:smathot/cogscinl 

Say yes/press enter to accept any requests.

sudo apt-get update

wait for it to complete, then:

sudo apt-get install zotero-standalone

This will install the program.

12
  • I try this code, but 'E: Unable to locate package zotero-standalone '. Aug 13, 2013 at 15:01
  • 3
    Working with 14.04 for me :)
    – nealmcb
    Mar 1, 2015 at 0:44
  • 4
    tried on 16.04 and works Aug 15, 2016 at 11:51
  • 1
    This works on later versions of ubuntu, but it can later on fail to update to later versions of Zotero, which severely diminishes its usefulness.
    – E.P.
    Nov 14, 2016 at 8:27
  • 2
    The following packages are no longer maintained: - Zotero standalone, a reference manager <zotero.org> For an alternative installer, see <github.com/retorquere/zotero-deb>
    – Will
    Apr 3, 2020 at 7:11
44

As of 2019, the preferred way of installing Zotero is by using Emiliano Heyns' packages.

Run the following instructions on your terminal:

wget -qO- https://github.com/retorquere/zotero-deb/releases/download/apt-get/install.sh | sudo bash
sudo apt update
sudo apt install zotero

For additional information about the provided packages, see the README file.

Other answers should be considered obsolete, Sebastiaan Mathot's packages being no longer maintained.

1
  • I ran into an problem with this -- it looks like the repo has a hosting problem and so the owner recommends installing from Sourceforge for now. For more info see the readme and issue github.com/retorquere/zotero-deb/issues/49
    – ascendants
    Dec 7, 2021 at 22:14
15

This project is designed to automate installation. It worked for me with 13.04. To install it, run the following in your terminal:

wget https://raw.github.com/smathot/zotero_installer/master/zotero_installer.sh -O /tmp/zotero_installer.sh
chmod +x /tmp/zotero_installer.sh
/tmp/zotero_installer.sh

and answer the questions. If you want it to be installed globally, you will need sudo on the last command:

sudo /tmp/zotero_installer.sh
5

I have installed Zotero on Ubuntu 20.04 LTS recently.

This is how I have done:

  • First I downloaded the tarball from the Zotero Download page, extract its contents to a folder named Zotero_linux-x86_64.
  • Then I ran the following commands in the terminal:
sudo mv -v Zotero_linux-x86_64 /opt/zotero/
ln -s /opt/zotero/zotero.desktop ~/.local/share/applications/zotero.desktop
sudo /opt/zotero/set_launcher_icon

That's it. The installation's completed.

5
  • 1
    Last command should be 'sudo /opt/zotero/set_launcher_icon', or cd to /opt/zotero/ before it.
    – timanix
    May 15, 2021 at 20:55
  • I have updated it, thanks.
    – raf
    May 16, 2021 at 2:22
  • 1
    Very straightforward, and the only answer where setting zotero.desktop worked, +1 thanks!
    – jay.sf
    Aug 28, 2021 at 17:20
  • @jay.sf I'm glad to know that my answer has helped you.
    – raf
    Aug 28, 2021 at 17:25
  • 1
    The answer I avoided out of lazyness but the only one that delivered me the newest zotero version I needed.
    – Ben
    Dec 2, 2021 at 8:46
3

It's 2022 and Zotero is available as a snap in Ubuntu. A version of Zotero can be installed without having to add additional repositories (although you may get a more recent version if you do use some of the techniques from other answers).

To install:

snap install zotero-snap
1

I have searched and came to know that , there only standalone Zotero PPA not yet made for Ubuntu 13.04 . you can run it as you've done with the script upto PPA made.

but Ubuntu have a good Documentation for Zotero that can help you to get more information on usage of it.

https://help.ubuntu.com/community/Zotero

1
  • Thanks! I make it a startup application and this will be ok. Aug 14, 2013 at 6:48
1

I found a help here https://www.linuxhelp.com/how-to-install-zotero-in-ubuntu/

The steps in the terminal are

  1. sudo add-apt-repository ppa:smathot/cogscinl

Type your password and press ENTER when asked.

  1. sudo apt-get update

  2. sudo apt-get install zotero-standalone

This will install Zotero

3
  • 3
    Same thing as described in askubuntu.com/a/332117/15003.
    – edwinksl
    Aug 3, 2017 at 17:19
  • 2
    How is this answer different from @Boluc Papuccuoglu's? add-apt-repository is a symlink, this should have been a comment below the aforementioned answer at most.
    – Calimo
    Oct 23, 2017 at 12:00
  • 1
    Also they are no longer maintaining it.
    – TKH
    Apr 15, 2020 at 19:04
0

The zotero installation page has decent instructions but they should have supplied the commands. Below are the commands I used (assuming the downloads folder is where your downloaded tar ball ended up):

cd /opt/
sudo mkdir zotero
cd ~/Downloads/
sudo tar -xf Zotero-6.0.9_linux-x86_64.tar.bz2 -C /opt/zotero/
cd /opt/zotero/Zotero_linux-x86_64/
sudo ./set_launcher_icon
ln -s /opt/zotero/Zotero_linux-x86_64/zotero.desktop ~/.local/share/applications/zotero.desktop

A quick script could be made from these simple commands if desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.