1

I just upgraded to raring, and accidentally installed proposed updates.

Now Chrome and Sublime Text are not drawn correctly.

Here is my sources.list

#############################################################
################### OFFICIAL UBUNTU REPOS ###################
#############################################################

###### Ubuntu Main Repos
deb http://sa.archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://sa.archive.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse 
deb http://sa.archive.ubuntu.com/ubuntu/ raring-updates main restricted universe multiverse 
#deb http://sa.archive.ubuntu.com/ubuntu/ raring-proposed main restricted universe multiverse 
deb http://sa.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu raring partner

###### Ubuntu Extras Repo
deb http://extras.ubuntu.com/ubuntu raring main

##############################################################
##################### UNOFFICIAL  REPOS ######################
##############################################################

###### 3rd Party Binary Repos

#### Banshee - https://edge.launchpad.net/~banshee-team
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6E80C6B7
deb http://ppa.launchpad.net/banshee-team/ppa/ubuntu raring main

#### Dropbox - http://dropbox.com
## Run this command: sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E
deb http://linux.dropbox.com/ubuntu/ raring main

#### GetDeb - http://www.getdeb.net
## Run this command: wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
deb http://archive.getdeb.net/ubuntu raring-getdeb apps

#### Gimp PPA - https://launchpad.net/~otto-kesselgulasch/+archive/gimp
## Run this command: sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 614C4B38
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu raring main

#### Google Chrome Browser - http://www.google.com/linuxrepositories/
## Run this command: wget -q https://dl-ssl.google.com/linux/linux_signing_key.pub -O- | sudo apt-key add -
deb http://dl.google.com/linux/chrome/deb/ stable main

#### Google Earth - http://www.google.com/linuxrepositories/
## Run this command: wget -q https://dl-ssl.google.com/linux/linux_signing_key.pub -O- | sudo apt-key add -
deb http://dl.google.com/linux/earth/deb/ stable main

#### JDownloader PPA - https://launchpad.net/~jd-team
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6A68F637
deb http://ppa.launchpad.net/jd-team/jdownloader/ubuntu raring main

#### LibreOffice - http://www.documentfoundation.org/download/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1378B444
deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu raring main

#### Medibuntu - http://www.medibuntu.org/ 
## Run this command: sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update
deb http://packages.medibuntu.org/ raring free non-free 

#### Oracle Java (JDK) Installer PPA - http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
deb http://ppa.launchpad.net/webupd8team/java/ubuntu raring main

#### Ubuntu Tweak PPA - http://ubuntu-tweak.com/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0624A220
deb http://ppa.launchpad.net/tualatrix/ubuntu raring main

#### UNetbootin - http://unetbootin.sourceforge.net/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FC91AE7E
deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu raring main

#### X Updates - https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu raring main

Edit :

$ sudo lspci -v | grep -A10 VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 8340
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at f7f00000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at dc00 [size=8]
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    Memory at f7ec0000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Kernel driver in use: i915
5
1

Okay, all seems fixed now.

The problem with Chrome was because of an error in the upgrade

Processing triggers for hicolor-icon-theme ...
(gtk-update-icon-cache-3.0:757): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory
This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

Reinstalling the pixpuf packages and installing the last upgrade fixed the bug in Chrome

sudo aptitude reinstall gir1.2-gdkpixbuf-2.0 gtk2-engines-pixbuf libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common</pre>

For Sublime-text, the bug came from the soda theme that I installed a long time ago (it didn't like the last update...) removing the theme from configuration fixed it :

Sublime Text 2 > Preferences > Settings > User I removed theme: Soda Light.sublime-theme

0

You could try to revert to a stable version of xorg and disable compositing. To do so, open your terminal window and run the following commands:

sudo apt-get update
sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo apt-get dist-upgrade

You should then be using the stable release of xorg.

To disable compositing, open the Settings Manager and select Window Manager Tweaks. Under Compositor, disable the Enable display compositing option

Not the answer you're looking for? Browse other questions tagged or ask your own question.