After reading and trying many different suggestions for some hours, I returned to this how-to:


The first problem I encounter is how to identify which of the listed drivers support my Nvidia GEForce 630M graphics card. Following the links doesn't really help, since it is not stated there either (except where support for a new driver was added later which is explicitly stated, but the original devices covered are not).

However, even if I knew, if it doesn't appear in the 'Additional Drivers' dialogue (see below), how will I install it?

Second Issue:

The article goes on to say that available drivers for my hardware are usually listed in 'Additional Drivers'. In my case, they aren't. Unfortunately, it doesn't tell me how to correct that or work around it?

I've checked the bios and there is no way offered there to disable the integrated graphics, only the Nvidia graphics.

I've also tried each available option in this:

$ sudo update-alternatives --config i386-linux-gnu_gl_conf

My system is an Acer Aspire 4752G bought May 2012.

I'm running Ubuntu 12.04LTS.

uname -a :

3.2.0-38-generic-pae #61-Ubuntu SMP Tue Feb 19 12:39:51 UTC 2013 i686 i686 i386 GNU/Linux

It's 64bit hardware but I installed 32bit OS for greater software compatibility.

Running $ sudo tail -fn 500 /var/log/Xorg.0.log | grep '(EE)' returns"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    28.886] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

The reason for wanting the proprietor y drivers is because my laptop comes with 3D accelerated graphics adaptor and so rather than confining myself to struggling with the on-board graphics, I would rather use it. I also want to experiment with using it for bitmining (which uses the GPU's for computing power).

  • "[...]there is no way offered there to disable the integrated graphics, only the Nvidia graphics." Yes, that is how it is supposed to be. – LiveWireBT Oct 28 '13 at 6:25

I installed cuda on ubuntu 12.04 as package as shown on NVIDIA website.

The graphic samples where not working saying:

hasan@ubt:~$ glxinfo | grep renderer 
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

The link http://forum.ubuntuusers.de/topic/kubuntu-und-nvidia-mit-proprietaere-treiber/2/#post-5901377 helped me.


sudo apt-get purge nvidia-319-updates nvidia-settings-319-updates nvidia-prime
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install xserver-xorg-lts-raring
sudo apt-get install nvidia-319-updates nvidia-prime
sudo reboot

Check with glxinfo | grep renderer. It showed on my Laptop:

OpenGL renderer string: GeForce GT 650M/PCIe/SSE2  

The Cuda graphic demos worked!


This is a Nvidia Optimus laptop. That means there are two video cards in it, a low-powered Intel integrated one with nice open source drivers to handle most things and then the Nvidia 630M to offload things for rendering.

The standard driver setup cannot handle this yet. To use this you currently need to install The Bumblebee Project and then run things with optirun (also on that page).

  • Thanks. Looking into Bumblebee in greater depth (installed it a few hours back) but perhaps you could explain the relevancy of the first link in your post? It doesn't seem to be related to whether or not my laptop is a 'Optimus' laptop (whatever that is). – Peter Snow Aug 13 '13 at 11:46
  • The first link shows a hardware breakdown of your laptop... Notably that it has two graphics cards. – Oli Aug 13 '13 at 12:15
  • I've just removed my earlier installed bumblebee and re-installed it in full accordance with the new instructions provided. The command I ran after removing the former was: sudo apt-get install bumblebee virtualgl virtualgl-libs-ia32 linux-headers-generic-lts-quantal. I then rebooted and checked Xorg.0.log again but the error Failed to initialize GLX extension (Compatible NVIDIA X driver not found) was still there. – Peter Snow Aug 13 '13 at 12:18
  • Just read this en.wikipedia.org/wiki/Nvidia_Optimus which was very informative (but didn't solve my problem). – Peter Snow Aug 13 '13 at 12:31
  • How can I confirm whether Optirun works when I place it in front of a command to launch a program? Is there a way to test Optimus or at least confirm that it is able to use my discrete GPU? – Peter Snow Aug 13 '13 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.