2

Possible Duplicate:
Add Matlab to main menu

Hello,

I am trying to install MATLAB. I got it installed, but I am having a hard time getting the launcher icon to work using the instructions from here. I get a icon in my Applications > Programming taskbar but when I click the Matlab launcher icon, it gives me an error saying:

Could not launch 'MATLAB R2010a'
Failed to execute child process
"matlab" (No such file or directory)

How can I fix this? As an alternative route, is there another way to launch matlab without the MATLAB launcher icon?

Thanks! :)

  • for launch, try typing matlab in terminal. use tab to see if there is any autocomplete. – sazary Apr 2 '11 at 23:40
  • nope, does not work... – O_O Apr 3 '11 at 0:10
2

As you said typing matlab doesn't work. I use it this way:

  1. change to MATLAB current folder

    cd Documents/MATLAB
    
  2. then, where I have my MATLAB installed:

    sh
    /home/my_name/Applications/R2010a/bin/matlab
    
  • Ah, I see the matlab file. This works executing the Matlab program. Now if only I can get that launcher icon to work... Don't know if you have any ideas to get that to work, do you? :) Thanks, nevertheless. – O_O Apr 3 '11 at 1:25
  • 1
    Unfortunately, even I don't know how to get the launcher to work. I tried using 'Edit Menus' and adding 'New Item' to menu but even with the same command as given above it didn't work for me. I tried removing sh but no luck! So I use the method shown above. – Chethan S. Apr 3 '11 at 1:35
0

Try to put this in launcher:

/usr/local/MATLAB/R2010a/bin/matlab -desktop

(or just change the root to your installation folder and put /matlab -desktop)

you can read more information here:

Add Matlab to main menu

Not the answer you're looking for? Browse other questions tagged or ask your own question.