4

I have installed Ubuntu 13.04 in Vmware workstation in my windows7 OS. I installed VMware tools in Ubuntu.

I have configured the shared folders in settings. Using the below command, I am able to get shared folders

/usr/bin/vmware-hgfsclient

But the shared folders are not present /mnt/hgfs

I tried to install Vmware tools multiple time but no luck.

3 Answers 3

6

Follow the steps. It worked for me for ubuntu 14.04 LTS running in vmware.

Make sure open-vm-tools is not installed. sudo apt-get remove open-vm-tools

  1. Make sure the updates are done: sudo apt-get update

  2. Make sure git is installed sudo apt-get install git

  3. Run the command to get the tools from repository. sudo git clone https://github.com/rasa/vmware-tools-patches.git

  4. cd to vmware-tools-folder cd vmware-tools-patches

  5. Run the patch sudo ./download-tools.sh

  6. Run the following patch sudo ./untar-and-patch.sh

  7. Run the complie.sh file sudo ./compile.sh

4
  • It takes some time, but it works!
    – Eli
    Mar 15, 2016 at 11:44
  • I recently found shorter and simple solution. See below.
    – Eli
    Jun 29, 2016 at 12:25
  • I did all those steps and it didn't help. I have ubuntu 18.04 on both host and guest Oct 15, 2018 at 8:56
  • this doesn’t work anymore Nov 11, 2020 at 22:20
1

A good and short solution for me was:

sudo vmware-config-tools.pl

You may be needed to logout&login afterwords.

1
  • running it: sudo ./vmware-tools-distrib/bin/vmware-config-tools.pl, I get Unable to find the database file (/etc/vmware-tools/locations) Oct 15, 2018 at 8:57
0

What problems did you have installing VMWare tools? I had a similar problem. After installing VMWare tools, I followed these instructions: How do I mount shared folders in Ubuntu using VMware tools?

Running the vmware-config-tools.pl ( sudo vmware-config-tools.pl ) again, then rebooting solved the problem. The files are in /mnt/hgfs/[shared folder name]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.