Restarted my computer, and noticed that Thunderbird which is set to auto-start did not start. So I clicked on the icon on the taskbar, the box highlighted the icon, the cursor spun around for a minute and then just quit. I tried clicking the icon on my Cairo dock, and going into the start programs folder and clicking there, same thing. I tried to start it with a terminal command and got this error:

(process:3354): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

I tried reinstalling with Synaptic, still no luck. I don't want to uninstall and lose all my settings unless I just have to. So does anyone have any other ideas, before I uninstall?

EDIT New Info; ardvark, I did post on both boards because I don't know if its a TB problem, or a Ubuntu problem. Now the response I got over there lead me to open system monitor and I found that TB was still running in the processes, so I ended the process, still would not start, Then had to do a gksudo nautilus, and delete a lock, and parentlock file inside the TB folder. Tried to start the TB -profilemanager, error said file did not exist. Uninstalled and reinstalled tried to start nothing, tried to start with terminal and got the error

(process:3637): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

Then I noticed that I am still getting my new email msg popups. So it's running somewhere.

vfbsilva First that was the whole error msg (on both of them). I tried to start with the command "sudo thunderbird" error was

(process:4261): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(thunderbird:4261): IBUS-WARNING **: The owner of /home/robby/.config/ibus/bus is not root!
07:32:15 INFO firetray.Handler OS=Linux, ABI=x86_64-gcc3, XULrunner=17.0.8
07:32:15 INFO firetray.Handler inMailApp=true, inBrowserApp=false, appHasChat=true
07:32:15 INFO firetray.Handler isChatProvided=true 

The link you gave me was for FF, and I was unsure how to change the chown command to point to TB. Everyone thanks for the responses.


I don't know if I had the same exact bug as you, but I had something very similar. Thunderbird crashed (this is my 2nd day using it and I'm already 110% frustrated with it) and then wouldn't reopen.

/home/mhaase $ thunderbird

(process:11979): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

On a hunch, I wondered if there was still somebackground process...

/home/mhaase $ ps aux | grep thunder
mhaase    2655  5.2  2.0 1720260 341164 ?      Sl   Jan26  45:39     /usr/lib/thunderbird/thunderbird
mhaase   12036  0.0  0.0  12164  2080 pts/8    S+   09:19   0:00 grep --color=auto thunder

After killing that process, Thunderbird starts normally.

| improve this answer | |

I had the problem this afternoon, though this morning was OK. Thunderbird would not start from the normal icon, and from a terminal it gave me:

"GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed". 

What I did was open htop from the command line, search for thunderbird (there were numerous instances showing up there) and kill one of them. That kills all of them. Then Thunderbird started normally.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.