I installed the ubuntu 12.04 into my flash drive to create a bootable usb stick. The first time boot is smooth with no issue. But after played around with it and rebooted it, the ubuntu could not get start. I tried both pendrivelinux and universal-usb-installer to create the bootable usb. They both have the same issue, but giving two different errors. The previous one stops with "kernel.thread helper" error. The later one ends up with a shell command environment, but can't boot ubuntu. My flash drive is 4 GB, and I reserved 2GB room for the persistence. So I can see a 2GB casper file in the flash drive. After I delete this file, I can boot the ubuntu system again. So I guess it might be some issue with loading the persistent data. Any thought about how to fix this issue? Thank you very much!

  • 1
    Please describe your actions more precisely. What do you mean for 'playing around'? Do you install/update packages there? – Danatela Aug 12 '13 at 2:20

I had bad luck with the casper-rw file too. For some reason I couldn't either boot my ubuntu usb with persistent changes nor mount it from within an installed ubuntu OS. It's something weird about my laptop hp 420 I guess, because my casper-rw file worked fine in other computers.

Anyway if you still want to boot it without persistent chances AND without deleting the casper-rw file, you can do that by deleting the "--quiet", "--splash" and "--persistent" arguments from the kernel parameters entry at the very start of the booting of ubuntu. I don't know to make those visible from USB isos created with other programs, but with unetbootin you do this by pressing tab after selecting your boot option.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.