1

I am using Ubuntu 12.04 LTS on a 7,1 Macbook Pro (4GB , Intel® Core™2 Duo CPU P8600 @ 2.40GHz × 2) and my system has suddenly started to take a very long time to boot after I log in. If I restart or start up my computer and log into Ubuntu, I only see the desktop for 20-30 seconds until everything else appears. If I log out and log back in, the system fully boots (as in I can see the launcher, panel, etc.) after just 3-4 seconds.

I tried to look at any error logs by typing dmesg into terminal and I get the following error looping over and over again. I am a beginner and do not know if this error log is related to my slow boot, and this is the first time I check the dmesg output. I am using proprietary broadcom drivers for Wifi without any problems (at least no problems that I am aware of - my speed is fine and consistent with what I get on my OS X partition)

[ 2433.373324] net_ratelimit: 14 callbacks suppressed
[ 2433.373335] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
[ 2433.373345] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
[ 2433.373502] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
[ 2433.373511] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
[ 2434.373196] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
[ 2434.373209] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
[ 2434.373286] ERROR @wl_cfg80211_get_station : Could not get rate (-1)
[ 2434.373293] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)
[ 2435.372913] ERROR @wl_cfg80211_get_station : Could not get rate (-1) 
[ 2435.372917] ERROR @wl_cfg80211_get_station : Could not get rssi (-1)

Details of my wireless card, as suggested by chili555:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

I tried to pipe dmesg into less and all I could see were similar messages, though occasionally I see "10 callbacks supressed".

Is this what is causing my slow boot? If so, how do I fix this?

  • Please edit your question to add detail about your wireless card. Open a terminal and run and post: lspci -nn -d 14e4: – chili555 Aug 11 '13 at 15:23
  • The Broadcom STA driver wl is correct for your device. Please see this bug report: bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1114281 This particularly affects 12.04. You can fix it by upgrading to 13.04 or we can change the driver to a later version, your choice. The suggestions to use b43 and firmware is doubtful for your device. Whatever you'd like to try, I will be pleased to help. – chili555 Aug 11 '13 at 20:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.