2

I have installed Ubuntu 12.04 and I want to install nepomuk-core-dev in order to build plasma media center ( http://sinny.in/node/25 ) but I am getting following error:

vijay13@ubuntu:~/plasma-mediacenter/build$ sudo apt-get install nepomuk-core-devReading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nepomuk-core-dev

and following error while building :
-- Found KDE4Workspace: /usr/lib/cmake/KDE4Workspace/KDE4WorkspaceConfig.cmake 
CMake Error at CMakeLists.txt:7 (find_package):
  Could not find module FindNepomukCore.cmake or a configuration file for
  package NepomukCore.

  Adjust CMAKE_MODULE_PATH to find FindNepomukCore.cmake or set
  NepomukCore_DIR to the directory containing a CMake configuration file for
  NepomukCore.  The file will have one of the following names:

    NepomukCoreConfig.cmake
    nepomukcore-config.cmake

-- Found Soprano: /usr/include  (found version "2.7.5", required is "1.99")
-- Found taglib: -L/usr/lib/x86_64-linux-gnu -ltag
-- Taglib found: -L/usr/lib/x86_64-linux-gnu -ltag
-- Found taglib: -L/usr/lib/x86_64-linux-gnu -ltag
-- Taglib found: -L/usr/lib/x86_64-linux-gnu -ltag
*** QtMultimediaKit (included in Qt-Mobility) is required at runtime to play multimedia.
*** You can download it from http://get.qt.nokia.com/qt/add-ons/qt-mobility-opensource-src-1.2.0.zip .
-- Configuring incomplete, errors occurred!
  • sudo add-apt-repository ppa:kubuntu-ppa/backports and then sudo apt-get update solved issue. – Vijay13 Aug 11 '13 at 13:41
  • You notice that the instructions you were following say "For Ubuntu 12.10 and higher" right? – Seth Mar 30 '14 at 17:46
2

sudo add-apt-repository ppa:kubuntu-ppa/backports and then sudo apt-get update solved issue.

Vijay13 solved the problem in a comment.

0

The guide you are following is only for 12.10 and up. It will not work on 12.04. The nepomuk-core-dev package, is not included in Precise (12.04) repositories. You have to use Quantal or later to get the package directly in your repositories. For building software is recommendable to use the latest versions of Ubuntu instead the Long Term Support (LTS), since newer versions has newer packages that you will need if building from source (normally, the software developers keep their libraries updated).

To see in what versions of Ubuntu the package is included check http://packages.ubuntu.com/nepomuk-core-dev

| improve this answer | |
  • It doesn't need to change the OS since the nepomuk-core-dev package can be found in a PPA... – Radu Rădeanu Mar 30 '14 at 16:56
  • @RaduRădeanu and? I don't rely on PPA's if there's something that works, and less in LTS where people looks for stability – Braiam Mar 30 '14 at 16:57
  • 1
    And... Nothing more. It's a bad answer in my opinion and I vote down when I see an answer that is clearly and perhaps dangerously incorrect. I also know that is nice to leave a comment when I take this decision (vote down). – Radu Rădeanu Mar 30 '14 at 17:05
  • @Braiam It comes to the same thing in the end, which is why your comment was removed. Be nice and understand people won't always agree with you. – Seth Mar 30 '14 at 17:38
  • @RaduRădeanu have you ever read the question? Let me quote something for you "Only you need to do is, follow the steps which are mentioned below. Required packages .... Ubuntu (12.10 and higher versions) ..." so? You still think is "wrong"? – Braiam Mar 31 '14 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.