Running a regularly updated 10.04 LTS we have a weird issue with access to audio with pulseaudio 0.9.22. Sound device is ATI Technologies Inc SBx00 Azalia (Intel HDA)

  • Login user1 after reboot: sound OK
  • Login user2 after reboot: sound OK
  • Login user1 then user2: sound OK: both have sound


  • Login user2 then user1: only user2 has sound
  • Login user2 after boot, logout user2, then login user1: no sound


  • Login user3 then user1: all is good!

In the two latter cases user1 is getting repeated errors in syslog:

protocol-native.c: Denied access to client with invalid authorization data

These errors disappear only after pulseaudio is started from user1 manually in a terminal. Then audio access is fine for both. There is an error module-alsa-card.c: Failed to find a working profile but still sound output is fine.

We both are not a member of the Audio Group. Deleting ~/.pulse from both accounts has no effect on this behaviour.

The issue started in 9.10 Karmic and continued to be there even after an upgrade to 10.04 Lucid LTS. This indicates that some erroneous settings survived the upgrades.

The dependency on boot order of users indicates that some other user specific settings may be involved, but we have no idea where to start searching. From tests with 3 users it seems that only settings for user2 are broken.

Loading pulseaudio modules module-esound-protocol-unix and module-native-protocol-unix with the option auth-anonymous=1 in both default.pa, and system.pa did not change this behaviour. Neither did it help to delete pulseaudio cookies ~/.esd_auth and ~/.pulse-cookie from both users.

Added here is our default.pa and our system.pa.

Suggestions 1) to 8) from the answer below did not make a change (running pulseaudio in system mode was not possible) but unplugging the external speaker, rebooting, plugging the speaker back in and reboot again from user1 did the trick.

It is still unclear where this hardware information was (erroneously) stored and why it affected only one user account.

  • I was having a similar issue when i was in 10.04. When i moved to 10.10 it was solved. For example i would login with my normal user, but i ever went and logged FIRST with my other account and then with my normal user several programs and even the login sound would not play. The only solution was to reset. I am pretty sure some ALSA update fixed this. – Luis Alvarado Apr 11 '11 at 11:55
  • @CYREX: I was already thinking of upgrading even if I'd rather stick to LTS on that machine. Before doing so I need to be sure that it's not user settings from $HOME that would spoil the whole upgrading thing. Did you upgrade or made a fresh install? – Takkat Apr 11 '11 at 13:08
  • Sorry Takkat, made a fresh install. Did not think of the $HOME at that moment. – Luis Alvarado Apr 11 '11 at 13:21

1) Would you please try this with user1:

sudo gpasswd -a user1 pulse-access
sudo gpasswd -a user1 pulse-rt
sudo gpasswd -a pulse audio

2) Have you tried this?

" edit /usr/local/etc/pulse/system.pa and add:

load-module module-native-protocol-unix auth-anonymous=1

Reference: https://tango.0pointer.de/pipermail/pulseaudio-discuss/2009-January/002942.html

3) Try running pulseaudio in system mode

Reference: https://bugzilla.redhat.com/attachment.cgi?id=262541

4) Make sure user2 does not run pulseaudio as root

5) Remove applications from user2 that may not release audio (e.g. timidity)

6) Go through ~/.asoundrc and /etc/asound.conf if present

7) Check if "the evil libflashsupport library" is installed. To uninstall:

 sudo aptitude purge libflashsupport flashplugin-nonfree-extrasound  

8) Start pulseaudio daemon system wide:

gksu gedit /etc/default/pulseaudio  


9) Try unplugging audio hardware like external speakers and reboot.

  • Edited your answer to accept it ;). All stable now. Yor answer is a very nice approach on how to troubleshoot audio. Hope it will get many upvotes :) – Takkat Apr 20 '11 at 17:01
  • Awesome! The "sudo gpasswd -a user1 pulse-access" part did the trick here after upgrading from 12.04 to 13.10 and having my (system mode) PulseAudio server refusing to play anything :) Now to figure out how to get XBMC to actually use pulseaudio! Thank you! – DanielSmedegaardBuus Oct 29 '13 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.